Sustain pedal muting Mono input?

Hey guys,

My sustain pedal connected trough my MPK61 is doing the job its supposed to but its also muting my mono input. I found that when setting up transport control on mpk61 it also affected the synth i had selected as well as do transport, so i used midi filters i found instructions for. Will it be the same for sustain can anyone give any idea?


I’m guessing that your sustain pedal is also triggering something in your Generic Remote Device. If you are not using it on purpose, open the Generic Remote, from the Devices Menu>Device Setup, and set its input to “not connected”.

Hi Vic,

I found your response in an other thread thank you. But I am using my remote for something else. I have been setting it up all morning haha, in 2013 they still have midi very messy! Anyways how i fixed the sustain issue while keeping my remote working was using the midi learn and triggering sustain pedal.

Now my other issue. How do i save these midi settings to remain. I applied settings each time. But when re opening cubase it no longer works. I have to start all over again.


Even though the answer might seem illogical, you get the GRD settings to stick, by Exporting them (yes!.. no need to re-import them!)

Lol wth. haha. Man come on steinberg!! JK… Thank you Vic!!

Having to remove all instances that say 64 in generic remote seems to be the only thing that works here. But How do i get the faders on my MPK to only control one thing. Mine is controlling the mixer faders and the volume of individual instruments output volume?

Hard to say, without seeing your setup. Could be either that your faders are set up incorrectly in the Generic Remote, or could be that the faders are correct in there, but also sending valid CC# data to the Instrument when a MIDI/Instrument track is record-enabled.
To check for the latter, try one (or both :wink: ) of two things…
a) make sure that no MIDI/Instrument track is record/monitor-enabled. Are the faders still controlling more than they should be?
b) temporally switch the input of the Generic Remote to “Not Connected”, and see if the faders are still controlling something when a MIDI or Instrument track is record/monitor-enabled.
If the “doubling” is happening because of the MIDI/Instrument track, then you should try using the track’s Input Transformer to filter out the unwanted CC# data.

If the problem persists when no MIDI/Instrument track is record-enabled, then, you are just going to have to look thoroughly in the Generic Remote, and double-check that there are no conflicts. Btw, do you have more than one Generic Remote active?