Sustain Pedal Problem in Cubase 6 Only

Hi all.

Thanks for reading this.

I just built a new PC and installed Cubase 6 and Komplete 7 about a week ago. Everything seems to be working perfectly with one exception:

When I play any piano in Kontakt 4 as a stand-alone (say the New York piano), the sustain pedal works properly. Holding the pedal down performs exactly like a real piano should. However, when I load the exact same piano in Kontakt 4 within Cubase 6, the sustain pedal acts differently. It’s difficult to explain.

For example: When I play a stacato note with the pedal down in stand-alone mode, there is a very slow decay for perhaps more than a minute… the sound’s decay is a long, smooth ramp to off… what a normal piano does. But in Cubase, with the pedal depressed, the stacato note ends as soon as the keys are released, leaving only a small remnant of sound to decay. Letting off the pedal stops the remnant. It’s the same with the instrument’s reverb turned all the way down. (And no, there are no effects on the track). Perhaps it’s behaving a bit like a sostenuto pedal instead of sustain, except the Keystation 88es only has a sustain and volume jack.

I’m using a new M-Audio Keystation 88es as my MIDI controller and that has been reset to default values (Depressing “Advanced Functions” button and hitting C#3).

I’ve tried different samples, of course rebooting, confirming that the sample settings in Kontakt were the same in stand-alone and within Cubase (seemingly), and a different pedal. Both of my pedals transmit MIDI data properly and work perfectly when I use Kontakt as a stand-alone.

Any ideas?

Thanks a lot.

Recently I encountered the exact problem you have described, and i also use the Keystation 88es from m-audio. I have Cubase 5, and I don’t know if there is much of a difference in the device setup menu, but this is how i fixed the problem: go to device setup. click on MIDI port Setup. You should see your keystation 88es listed to the right (listed as USB Keystation 88es In [1], and USB Keystation 88es Out [1]. if any more Keystation 88es are listed (such as 2 - USB Keystation 88es In [1], etc.) make sure to uncheck the boxes under VISIBLE and In ‘All MIDI Input’. Hit a note while pressing the sustain pedal, and it should now be functioning exactly as it would in stand alone mode. hope this helps.
CUBASE IMAGE.png