Swells Playback (Percussion)

I’m having an issue with swells playback in Dorico 3.
I have tried using Halion and Noteperformer 3.

The issue appears when using tremolo markings combined with dynamics. In the attachment is an example of a timpani roll.
Normal swells play back just fine…

Thanks in advance!
1.jpg

As already discussed by email, the issue here is that dynamics are resolved before the extra notes required for playback of notations like tremolandos and glissandos are generated, so the per-note dynamics are not applied to those notes. We expect to resolve this in a future update.

In fact, I think I’m mistaken about the cause of this issue, since it’s possible to get a crescendo on a timpani roll with the ‘HSSE+HSO (Pro)’ playback template. I’ll come back to you again soon.

Hi, same problem here with timpani rolls using noteperformer.
If i write all the notes the playback is correct as in bar 71 in attached file but the crescendo doesn’t playback in bar 73 with the tremolo notation.
The problem also occurs with measured tremolo and with other percussions such as cymbals.

For the time being there’s no automatic playback of dynamics on percussion rolls; it happened to work before the most recent update to NotePerformer changed the way dynamics are handled to improve the way e.g. piano dynamics work. But if you add some automation for MIDI CC7 (channel volume) in Play mode you should be able to simulate the change of dynamic for the time being. Handling this more automatically is of course on our backlog.

Thanks for the explanation Daniel.