Swing Playback not working (with Dorico 2.1 and Note Performer 3)

I’ve gone to Playback Options and chosen system-wide “Heavy Swing” and pressed play - no swing playback (in a piece that definitely has 8th notes, but was created using Dorico 2, not 2.1). Just to be safe, I also hit shift-P and inserted a “Heavy Swing” signpost right at the beginning of the score and hit play - still definitely no swing. What am I doing wrong? Is this new feature compatible with Note Performer 3 (which is what I’m using)? Thanks in advance -

  • D.D.

Isn’t this supposed to be shift-t?

Do you have an initial time signature? IIRC, it doesn’t work in open meter

Was your project imported via MIDI? If so, then it will have playback start and end offsets. You’ll need to select all the notes, then use Play > Reset Playback Overrides.

If I select everything (not just notes) and apply “Reset Playback Overrides” Dorico 2.1 crashes.
I created a diagnostic report. Where do I find it ?

It’s on your desktop.

got it :slight_smile: - here you are…
Dorico Diagnostics.zip (1.56 MB)

In fact, there’s no need to attach your diagnostics: I can see what’s wrong here. Dorico won’t handle the selection correctly if it contains non-note or rest events. We’ll fix this. Before you switch to Play mode and do Reset Playback Overrides, first use Edit > Filter > Notes and Chords to be sure you only have notes and chords selected.

That worked (at least for me)! - though the solution would definitely never have otherwise occurred to me…As long as I can get Swing, though, I’m ecstatic!

Thanks -

  • D.D.

The reason is (as we’ve covered in the other thread), if you have the option set to preserve the note timings on MIDI import then Dorico won’t touch them, as the meaning of it really is, ‘keep these notes how I originally played them’. If you reset the playback overrides then that removes the original note timings and lets Dorico swing and set note durations for articulations.

Excellent - thanks again (including for your impressive-looking and sounding implementation of swing playback!)

  • D.D.

I don’t know what I’m doing wrong. Although I didn’t import Midi and although I ‘Reset Playback Overrides’, I don’t get back Swing Playback. No idea why…
Swing.dorico (442.9 KB)

I made a complete new session, I re-started my computer, I set the playback mode manually in ‘playback options’ - nothing - no swing at all…

You have set swing for 16ths. There are no 16ths in your score!

I just recognized…damned…so stupid…thanx man !

No worries.

BTW it’s probably best if you start new topics rather than tacking on to 3yr old threads!