'Swing' won't apply to instrument tracks

Hi. I’m having a problem applying swing to my virtual instrument tracks and can’t figure out why. I get the quantize box open, select the midi events of a given track, choose the amount of swing, then hit ‘quantize’ (or do it on auto) and nothing happens. The beat stays the same. Am I missing something here? Any ideas welcome. Thanks,

Cubase 6.5 64 bit
Windows 7
Toshiba laptop

What are your actual Quantize settings? (It does work o.k. here :wink: ). I mean, if your selected notes are all 8th-notes, but you have the Grid Settings at 16ths, then you won’t hear any difference (it would “swing” any notes that happen between the 8ths, not the 8ths themselves :wink: ). To get the desired result in this instance, you’d need to set the Grid to 8ths.

Thanks Vic, I’ll try that out. Could well be it.