Switch between instrument tracks without cutting off sound?

Hey there,
I’m trying to use Cubase in a live performance situation, where I switch between different VST instrument tracks. My problem is, in the moment of switching from one VST track to another the sound of the previous instrument gets cut off. So now I’m looking for a way to let the previous instrument have it’s natural decay and release time and sound even when I already switched to the next VST track.
Thanks in advance for any suggestions :slight_smile:

Maybe try turning off ASIO guard?

1 Like

“Switch” means what exactly…?

I’m guessing that you’re enabling and disabling the audio output of the VST Instrument tracks when switching.

Conceptually, I would consider leaving the Audio enabled for all the Instrument tracks, and maybe try to switch the midi input monitoring on and off for the Instrument tracks in question?

1 Like

With switching I mean going from one instrument track to the next one below with the arrow keys (I attached some screenchots). I disabled Asio guard now but the problem seems to be the soloed tracks. If I don’t solo the tracks all instrument sound at the same time. If I do solo them the sound gets cutt of when I go to the next instrument track.

(1. screenshot= The outputs of the MIDI-tracks go to the different VSTs which u see in the second sreenshot)

Yeah that’s exactly what I did. But once again If I leave all the MIDI tracks with enabled input monitoring, they play at the same time. Perhaps it would work if only the selected instrument track would send MIDI data. Although I have no idea how to get there…

Also activate Record Enable on Selected Track and make sure midi thru is on for record-enabled tracks,

1 Like

What’s the maximum number of VST Instruments you’re trying to simultaneously play from your input controller?

At the most four.

I’ll try that although now I have seemingly found a workaround. I created a Macro including:

  1. turn off monitoring
  2. move down (to track below)
  3. turn on monitoring

also I turned off the solo on the tracks . Now it works

Guys thank a lot for the support! I hope someone else gets some use out of this thread :slight_smile:

I think it’s way simpler:

I would avoid the entire Solo strategy, because that cuts off volumes.

Then, one Midi track for each different combination of target Instruments.

For example tracks “Control 1”, “Control 2”, “Control 3” etc.

Each of the “Control” tracks uses one Midi Output and up to 4 MIDI Send slots to pass the midi to the target Instruments (maximum of 5 targets that way).

Control 1 ===> Instrument A, Instrument B, Instrument C
Control 2 ===> Instrument A, Instrument D
Control 3 ===> Instrument B, Instrument C, Instrument D

The Instrument tracks do NOT have monitoring enabled.

and then:

1 Like

Yeah that’s indeed way better. It works perfectly ! Once again many thanks :slight_smile:


geez… I thought I was losing it for a minute…

1 Like