Switch faders with the mixer’s bank select

When Cubase is updated to 12.0.51 or later and the various problems are fixed, will it be possible to switch faders with the mixer’s bank select?

Hm, it’s working fine here touchup. Are you sure you have made the right assignments for the faders?

1 Like

Sorry, I didn’t explain myself well enough.
The bank select in version 12.0.50 works fine on Cubase.
But I am using Maschine Jam as a MIDI controller.
The problem is moving the bank select on Maschine Jam.
I don’t know about other MIDI controllers, but with Maschine Jam, when I operate the fader of a channel moved by bank select, it returns to the original bank.
However, the bank select in version 12.0.50 moves the mute solo select correctly in Maschine Jam.
Except for this bank select, the Maschine Jam is the best instrument as a surface controller for Cubese.

That’s why I wonder if you have assigned the faders to control 8 channels of a bank, or if you’ve made a static assignment of the first 8 channels. That would be the first thing to check. Have you used the Surface Editor to set this up? Do the faders send more than one message when you touch the strip, or is it just one CC?

Unfortunately, I’m not familiar with the Jam, but maybe someone else is, and can join in with some advice.

1 Like



If you look at the image (Maschine Jam), you will see that I set the faders in Surface Editor.
The image (Maschine Jam-2) shows the Control Editor screen of Maschine Jam.
I don’t have much know-how. I don’t understand what you mean by CC.
My question is why “select”, “solo”, “mute”, etc. follow the bank select, but not “fader”.

Even though the language is impossible for me to understand, it seems that the assignments of faders in the mapping assistant is ok.

In the second picture however, I see that the jam’s strip is set to emit a note. This makes me believe that there are two parts to this fader. The “Touch” that first selects the channel (the note c-2), and the “Position” when you move your finger, which should probably be a CC that takes a value 0-127. I wonder if that’s what the “Position” tab is for? (in the second picture, on the right.)

And in the first picture on the right, where the fader is selected, are the settings Message: Note, Channel: 1, Note#: 0?

What if you look up in that “Position” tab from the second picture, see what values are there and use those for the faders? I think it’s the touch that throws off your banks fro your faders.

As you say, banking works ok for the channel specific buttons, like mute solo etc.

1 Like

Thank you very much for all your help.
In Maschine Jam’s controller editor, I set “Touch” to Off and “Position” to “Control Change” and it worked (Maschine Jam-2).
But there was one more problem.
Maschine Jam has a level meter next to the fader.
However, this level meter does not follow the bank select.
Don’t the level meters on other MIDI Remote Controllers also follow the bank select?
The image (Maschine Jam) is the MIDI Remote screen in Cubase.
The red area on the screen with the faders seems to indicate a misalignment with the actual fader position.
Can this misalignment be resolved?


That’s the Scaled mode at work. You can go into the mapping assistant, select all your faders (select first, shift click on last one) and change this to “Jump”. Now whenever you work a fader the value will directly go where you touch, it won’t wait to catch up with the last value the fader had.

Regarding the meters. I don’t know how to help you with this. Do the Jam lights expect the same message to come with the level data? (Chn. 1, CC 0, 0-127) If yes, you could manually add a simple lamp to each fader in the Surface Editor, and then make an assignment (select the lamp) for Mixer Bank Channel → Channel x → Meter All. So that when you change bank, the message will still be relevant to the right channel. But I’m not sure if that’s the way to go, I don’t want to have you waste your time.

1 Like

It’s fantastic!!!
Thanks to you, Machine Jam has been reborn.
All functions are now complete!
I have been doing DTM since DX7 came out (when MIDI started) and I have never received such precise support.
In Japan, they don’t offer this kind of support.
They don’t have the know-how to do so.
Thank you very much.
Thank you from the bottom of my heart.
Although it is a product of another company, Machine Jam is superior to other MIDI controllers in many ways.
You can set over 100 commands along with mixer functions.
I would like to help other users about Machine Jam.

2 Likes

Great! I’m glad your Jam now can do what you want it to do! :smiling_face:

1 Like

can you help me with my jam. i just want the faders two work. i have two maschine jams which i would like the faders on the jam to work the faders in cubase. if you can help me make the faders work the same way they work in maschine software with the light control. i just cant get it to work. im good with maschine but new to cubase. your help would be greatly appreciated