Switching among MIDI Tracks - changes displayed Range


I can’t figure out, how to change my settings or workflow for faster MIDI editing.

Problem is, I have got the Key Editor opened all the time, because I’m working 90% in this editor. But if I have opened Key Editor for the track 1, and switch to the track 2 (by selecting the region in the Arranger window), there is different range of bars, which are displayed in the Key Editor. Despite one track (and region) is above the second.

Track 1: region from bar 2 to bar 10.
Track 2: region from bar 5 to bar 10.

I’m working on bars from 7 to 9. The cursor (Playhead) is placed on bar 7. I select this region from track 1. In the Key Editor, it displays range from bar 2 to bar 4. I leave the cursor on same place, and select this region from track 2. The Key Editor displays range of bars from 5 to 7. But I would like to display range of bars from 7 to 9, anytime. There is the cursor on the bar 7. Why Cubase doesn’t display 7th bar on left of the Key Editor anytime, I open It in this case?

I know, I can display both tracks (regions) together in one Key Editor. But this is little bit different.

Can you help, please? Do you know, how to change my settings, please (I would like to mention, Linked Editors is switch to On in my settings).

Thanks for any advice!


I usually just hit CTRL + F everytime I change to a different editor. But I agree that this doesn’t work if you want to do detailed work on a certain short passage.

You mean just F key – Auto Scroll On/Off, right? Yes, it’s necessary to press it twice. Once it Switch Off this function, second, switch it On. And The Key Editor Window has to be active. So I have to prepair shortcut macro in my QuicKeys.

But you are right, this is only one way, which works to me too. It’s not user friendly, as I wrote, but… I like all-in-one-window apps for this!