Switching between parts in Key editor

I’ve been using Cubase for quite some time now and there’s still one thing bugging me the most because it doesn’t work. Maybe I missed a setting or something? If so please let me know: Picture this:

You’re into heavy editing a piece for string orchestra involving multiple tracks.

Suppose you have 8 tracks each with its own arrangement but similar parts. From bar 20 to 36.

If I open one part in the key editor and have the ruler at 32 and switch another part it always reverts to the beginning (20) of that. So I always have to press play and stop very quickly before this part realizes to play at ‘somewhere’ the same position where the ruler was at where I edited the former part.

I know I can select multiple parts and edit them at the same time? And then they will show up in the same timeframe at the cursur.

But sometimes I just want to keep the ruler at the same position in the key editor switching from one part to another. But for some reason the selected part always shows the beginning. Even tough the ruler is at 32?

Why is it not possible in Cubase?

This is really annoying! Or am I missing something?

Hi,

It’s design like this (unfortunately) in Cubase.

If new MIDI Part opens, the Key Editor jumps to the beginning of it. It’s specified like this. My workaround is to edit multiple parts at the same time, or Press F twice. This Auto-Scroll Off/On forces Key Editor to show the Cursor, so the focus of the Key Editor is around the Cursor, way I need.

Hi Martin,

Thanks for the reply. Yes I was already afraid it was by design :frowning:

But pressing F twice is better option than pressing play/stop because then the cursor will not be a the same position. Thanks for the tip!

New(ish) user here, started using Cubase again from 11.
Having exactly this issue as well, and i’m really sitting here, scratching my head over what could POSSIBLY be the reason to implement this behavior like this?!

If i select a different part at bar 2018, i DO NOT WANT TO GO TO THE START OF THE PROJECT (which happens if your part extends over the whole project).
What kind of thought process was involved here?

Also, where is the option to change this behavior?

How about pressing SHIFT+F for a starter? Then select portion of notes you want to edit and press ALT+S.
‘F’ needs to be turned on/off accordingly.

How about pressing SHIFT+F for a starter? Then select portion of notes you want to edit and press ALT+S.

So every time i click between parts i’m supposed to zoom out full extends, then select the area i was JUST LOOKING AT a second ago, and make it zoom in again, just because the editor doesn’t bother remembering the time range i was just editing? Does that sound like a logical workflow to you?

OK then, why not open all the part at once?

Because i don’t want to see all of them at the same time either.
Look, it’s really a simple, quite obvious, feature that was missed or mis-implemented here.

The click-once-to-edit behavior is very ergonomic, until the editor doesn’t skip to the currently edited time. Then it becomes rather aggravating very quickly.

Edit: there is even actual code in place to make the editor go to a specific position when a part is selected, so it’s not like a lot of additional work would be needed to let it go to a different position instead.