Switching modes

If I switch from input mode to engrave mode or vice versa, the screen jumps always to the first page of the document. Can this be avoided?

The easiest way is generally to keep something selected on the page.

Hi Leo! This does not seem to work for me.

For instance: if I have something selected in Write Mode, on page one, go to Engrave Mode, the screen jumps to page 3. Or if I have a note selected in bar 22 on page 6, it jumps to page 2. This is so frustrating. I waste so much time trying to find where I am in the score.

Nor does it for me - it is indeed tiring, and apart from that it would be very helpful if the displacements of some objects were enabled in write mode too, e.g. dynamics.

If you’re using galley view in Write mode, try using page view if you’re switching back and forth between Write and Engrave modes a lot; that way Dorico will not need to reposition the music at all when you switch mode.

I mainly work in page view!

Then in that case I’d definitely like to learn more about the problem, because that’s not how things should be behaving. To help me diagnose the problem, please provide me with some specific things:

– A screenshot of your whole desktop just before you make the edit, showing how things are positioned before you change mode or make an edit
– A screenshot of your whole desktop immediately after you change mode or make the edit, showing how things are positioned afterwards
– The project file itself
– A textual description of exactly what you did (e.g. what you selected in what instrument in what bar, what you then did, e.g. change mode or navigate with the arrow keys, etc.)

Then we should be able to dig in and find out what’s going wrong. Unfortunately the nature of these kinds of problems is that they can be extremely sensitive to things like zoom level, window geometry, the precise placement of the score in the window, and so on.

One thing to check: if you habitually use one of the Fit… zoom levels (like Fit page height), then try adjusting that zoom level by 1% so that it’s effectively the same zoom level, but Dorico isn’t trying to keep the page precisely in height at all times. What you will sometimes find when using one of the Fit… zoom levels is that the change in geometry of the score view between Write mode and Engrave mode, caused by the different panels you have open on the left and right of the window, can cause Dorico to have to recalculate the zoom level, and that can cause the view to shift (though it should always keep the selected item in view).

To adjust the zoom level by 1%, type Alt+Z to open the Custom Zoom dialog, hit the up or down arrow once, and then hit Return.

Thank you, Daniel, for your hint to the zoom-level: I was always using the “Show page”-option. If I use a %-value, the problem disappears indeed.