Switching to Dolby Atmos Ruined my whole project

Hi guys. I finished my song, I mixed it. after that I saved it as Dolby atmos project,
made dolby atmos in Cubase and it said I had to convert my project to 48khz so I did.
Now everything is ruined all my audio files if I play them separately. Some tracks are glitchy and some of them are playing normally. please help! :smiley:
Whole session is messed up. I tried everything…

Is there an auto save from before you saved with atmos? I tend to save as with a new name every time I do something big. It’s much better to start off with the right atmos settings although the buffer size they stipulate is restrictive for vst playing

Yes, I tried it, somehow audio files are changed so every backup i checked the same issue is going on…