Sync issue

Anyone have any idea of why its like this? Been driving me nuts. Yes, I use my ears in wavelab, but I know for sure that everything is quicker to dial in when things are in sync. Even the waveform display has the same kind of offset. I’ve been doing some cuts and pastes on a twotrack live recording, and its tricky when the playback-line and audio don’t match. Come on, Steinberg invented VST, it should be flawless.

Windows 10, two video recordings, same audio file, same PC.


Have to ask what Audio Interface and do you have the same
buffert/latency in Cubase vice versa WL ?
and I agreee it should be the same sync!

regards S-EH

What WaveLab version, and plugin used in the Master Section or Audio Montage? Vst2 or VSt3 plugin?

I’m using the prism lyra2 interface, and I always choose the 64bit version of the q3. Nothing else on the montage. Just downloaded cubase 10 LE demo to test this very issue. Did not change any setups.
I have not changed any buffer settings in wavelab.

Just did a check. Opened a new tab in wavelab, loaded only this audio file, a stereo file, 44.8/24
Loaded the FabFilter Q3 into the first slot of the master section.
The display is like over half a second in front of the audio.

I have tried Pro tools, Reaper, and now the demo of cubase 10 LE.

All perform flawelessly on this. They are completely in sync.

So I hope this can be fixed.


By the way, I bough the Plugin Alliance SPL Hawkeye metering plugin, it’s the same negative latency, ie it reacts before the sound.
It’s been like this always for me on my windows PC.
Just learned to live with it I guess, but I figured I’d try to check here if anything can be done…

PPS. Internal meters in wavelab are fine. It’s only the plugins that don’t work.

I cannot replicate it here. Could it be some buffering setup with your sound card or some buffering settings in WL. This must be a problem for you to be sure.

Do you see the same latency with Steinberg plugins? VST3 plugins that are standardized, should not expose this latency when used in the Master Section.

Hi Philippe, and thanks for your reply!

I just tried it now with Master rig, and the spectrum analyzer has the same of issue.
In Reaper this issue is not like this, and as mentioned with Wavelab stock metering it’s fine, but with the spectrum deisplay of VST3 plugins like FabFilter ProQ3 and proMB, the graph is ahead of the sound by a noticeable amount.
Steinberg studio EQ has the same problem.
Yesterday I downloaded the demo of Cubase Elements 10 just to check, and in there everything is spot on. Same computer, same soundcard with the same buffer settings. Reaper and Pro tools are also dead on. I’m at a loss here.

EDIT I think I figured it out!

In the preferences under AUdio in wavelab there is a setting called “Buffer number”
It was set to 32 for some reason. I scrolled it down as far as it would go, leaving it at 4, now it seams to sync.
Are these buffers in addition to the buffer settings of my soundcard, or what are these really?
Can I expect more glitches now?

Buffer number makes no difference to Steinberg Studio EQ meter sync here, it’s still in sync with buffer setting of 64. ASIO (tascam in this case) or MME internal, Wavelab 9.5.50 on Win 10. But I’m not using a Lyra, if the interface can make a difference.

Strange. It solved it here. High settings and all the graphs are way ahead of the audio.

Normally, VST2 plugins are sensible to the number of playback buffers, but VST3 standard plugins are not.

Hi again,

OK, then I probably need some educating…in my plugin lists, I get two instances of most plugins. One that has /// displayed in front of their names. I have always chosen these as I figured they are probably the VST3’s?

Tested it now, it’s when I go absurdly high on the buffer that I get these drift issues. So for me it starts to sync up around 14 on the buffer size. When I was at 32 it was unbearable. I don’t know why it was at 32, I’m sure it must have been me in frustration over some dropouts in rendering through outboard a while ago.

I tested now both the /// versions and the ones without the sign. No difference.

Yes, /// is the VST-3 symbol.

I still don’t understand why this happens to you and not to me, even if I go to 32 or 64 with the buffer, Steinberg EQ meter perfectly in sync, as I would expect if everything is being properly compensated (?). Does it happen with just the one plugin in the chain? Does it happen if you select MME built-in instead of the Prism? PG, does the interface driver have any bearing on this at all?

However, does it make a difference how much processing the plugin is doing. i.e. if the eq is flat and basically bypassed, is there no delay?

The plugins are both flat, im just testing the graphs.
Seams like the Steinberg eq is slightly better behaved, but the issue is still there. Could this be because I’m on an AMD PC that’s a few years old?