Synsopos.exe: DCOM connection fails on startup.

I submitted this note a few days ago but with a title that read as if my problem had been solved but it hadn’t been. Here’s the issue again.

I get the message, “DCOM connection to program ‘Synsopos.exe’ failed.” on starting Dorico, and a similar one on running eLicense Control Center: “Application ‘LCC2’ has caused the following error: DCOM connection to program ‘Synsopos.exe’ failed. Error: Unspecified error”

Another user had a similar problem and fixed it by undoing a quarantine of the file Synsopos.exe that his security program had tucked away. I had the free version of Malwarebytes installed until recently and I recall it undergoing a quarantining process I wasn’t paying attention to at the time. I may have quarantined the file myself and erased it when uninstalling Malwarebytes.

Can I simply replace synsopos.exe? If so, can anyone tell me 1) what subdirectory it belongs in and 2) how to ensure the synsopos.exe I use is the right one? The installation disk doesn’t apparently have an unbundled Synsopos.exe, but Windows Explorer shows me these 2 still on my PC:

C:\Program Files (x86)\eLicenser\POS\SYNSOPOS.EXE
Date modified: 8/29/2016 5:35 AM
Size: 1.98 MB

C:\Program Files (x86)\Syncroft\POS\SYNSOPOS.EXE
Date modified: 12/14/2011 11:21 AM
Size: 84.0 KB

It’s easiest if you run the installer for the eLicenser Control Center again. You can download the installer from here: https://www.steinberg.net/en/company/technologies/elicenser.html

What helped me was that I ran the installation software in administrator mode

  1. Completely uninstall eLicencer

  2. Restart computer

  3. Right click on installer software > click Run as administrator

  4. After installation, run the eLicencer also in administrator mode