System collisions

Hi! Why I’m I getting these system collisions?

Because the frame has a bit too much music in it, according to the staff size, the height of the music, the height in the frame, and the gaps required between everything.

The clue is the bottom-left frame fullness indicator: it’s red, and displays “106.2%”, meaning Dorico has calculated this frame (the blue area that takes up most of the page) to require 106% of its maximum vertical space.

Solutions are varied, but include:

  • Reducing the staff size for the layout. If you’re generally happy with that though, and don’t want to change the staff size –

  • Reducing Ideal and Minimum Gaps for the layout, to allow Dorico to move some staves closer together, and therefore reduce the minimum heights of these two systems

  • If you have Dorico Pro, reducing the minimum gaps between various items and the staff in Library > Engraving Options (such as letting dynamics be closer to the staff)

  • Checking you have positioned items in an ideal fashion: e.g. at rehearsal mark H, it’s sitting quite high, above the bracketed metronome mark. Is that a tempo item, or a text item? if it’s text, you can disable collision avoidance for it, which stops it pushing the rehearsal mark and the staff above so far away.

  • Inserting a frame break at the start of the 2nd system, to put it on the next page. That would leave only the top system on this page, which might look a bit sparse! So you could also show some empty staves here, to fill in the gaps. Or, shuffle earlier music around and fit the top system here on the same page as the previous system, if that system isn’t as tall as the bottom system here.

1 Like

Thank you! Changed Minimum gap for inter-staff from 1 to 2, and that solved this issue. But, I’m not sure why. It will take me some time to understand the theory and practice of Dorico here.

If you’ve got some time to kill, these videos are great on the topic: