System indents and staff names

In a multi-flow piece I’d like the first system of the first flow to contain full instrument names but to have no indent (the names provide enough indentation). In subsequent flows I’d like no instrument names but a small indent. Any setting to show instrument names without an indent applies to all flows and the only way I’ve found to make the subsequent movements (flows) to have no instrument names but a small indent is to insert a system break at the beginning and change the setting in the properties panel. Fortunately I can copy these to the beginnings of the next movements. The only way to get system indents at the beginning of the next movements is to do it manually in Engrave mode by enabling note spacing and dragging the first system handle to the right. I suppose I could have done this the other way around: a small system indent at the beginning of all flows which I remove in the first. This all seems kind of roundabout for something which would seem to be fairly standard practice. Am I missing something?

Layout Options > Staves & Systems has a setting for the indent at the beginning of a flow. Then change the first Flow with a System Break to show Labels.

I think the indent you add in Layout options>Staves and Systems should fulfill your needs : it won’t appear in the first flow, since the instrument names will probably be grater than this indent (and it is not added to the instrument names offset), and it will appear in subsequent flows, provided you don’t want the names to appear.
[Edit] Ben was faster than me. I guess you’ll know what to do now !

I was wrong about doing it ‘the other way around’. One can’t change a system indentation to have a negative number, so I have to set the indentation to zero for all flows and indent the beginning of subsequent movements manually, unless I’m missing something.

You both got in while I was experimenting! I just tried what you suggested and the indent is added to the instrument names, so I get an overly large indentation at the beginning of the first flow.

That may be the case, but if Flow 1 is “the odd one out” from all the other flows, it makes sense to do the manual adjustments only to Flow 1.

As I just discovered, one cannot move an indented system to the left or ‘un-indent’ it. In the situation I outlined above, one has to set all the flows to have no indent and perform the indentation at the beginning of each new flow. I can imagine this not being so obvious if each flow is to show the instrumentation, but in chamber music this is seldom, if ever, necessary. It’s too bad Dorico adds the indentation to the instrument names.

Do you need Abbreviated names? I’m wondering whether you could do an indent with “invisible” staff labels, so that they have width, but don’t show…?

That’s a clever idea, Ben! I’ll give that a try later.

Sorry Vaughan… I was not in front of my machine when I answered. I messed up with the minimum ident thing, which is not what you need here…

I have made a note of the suggestion that the indent at the start of the flow should optionally only take effect if there are no staff labels.

Thank you, Daniel.

I think I’m in a similar situation… I have several flows, but I only want to show the full instrument names in the first flow, and no instrument names for subsequent flows - but where do I set that?
Thanks

On the Staves and Systems page of Layout Options, set no staff labels to appear there; that will take care of every flow following the first. Then to show staff labels only at the start of the first flow, select the initial note or rest at the start of the first flow and insert a system break (in Engrave mode, type Shift+S), which will have no visible effect on the layout but will cause a system break signpost to appear. With that signpost selected, open the Properties panel and activate the Staff labels property, which you can now set to Full to show full instrument names just on that first system of the first flow.

That worked! I had noticed the “none”-option in Staves and Systems but I hadn’t figured that you could then show it again later on. Thank you so much for your help and the quick reply! Cheers!

Hi folks,
just wanted to check if what Vaughan Schlepp describes is possible by now? So basically having multiple flows, where the full instrument names are shown in the first flow only → so no instrument names (but with a small indentation!) for the subsequent flows. I also found a couple of older threads from '17 and '18 addressing the same issue.
Also, is alt+arrow still the only way to indent systems? It’s painfully slow and I just read a thread from 2018 where Daniel agreed that this should be easier in the future. So hoping that I’m missing something…

PS: Just discovered that benwiggy’s idea to use the abbreviated instrument names for the fake indents on subsequent flows works great in my case (as I don’t need the abbreviations anyway)! Still… an “official” solution for this would be nice :slight_smile:

Welcome to the forum, @Nick777. There’s no automatic way to control what staff labels appear at the start of each flow as yet. The best way would be to set the options in Layout Options to match what you want to appear for every flow after the first, then create a system break at the very beginning of the first flow, and override the staff label visibility via Properties for just the first flow.

Thank you for the speedy reply, @dspreadbury!

Unfortunately your suggestion doesn’t really help in this specific situation, as not the staff labels itself are the problem, but the indentation is (for exactly the reasons the op mentioned a couple of years ago).
It would be really helpful to have an easier way to control the indentation of systems (e.g. just type a number in the properties panel). Just to be clear, what I’m trying to archive is: Full staff labels at the beginning of the first flow. No staff labels, but a small indentation for the first system of subsequent flows. (The whole project – a song cycle – is using the same instrumentation throughout, no need to restate staff labels every flow. It’s quite common in chamber music in my experience.)
What I’ve done now is to change all the instrument names using alt+space, so that the abbreviated staff labels create some sort of “fake indent”. But would be great to have a better solution in the future.