System overload? Mac + Dorico 3,5 + NotePerformer


I have a 12 staff, five flows 17 minute piece with NotePerformer playback. Sometimes Dorico slows down and playback starts to hack / jump. I have to save/quit and restart.

Any idea what I can do?

MBP 16" 2,3 Ghz 8-core, 16GB RAM macOS Big Sur


Did you try increasing the buffer size? (Device setup) It might help… (although I have a Mac client with the same symptoms and it didn’t help for him :frowning: )

1 Like

That “shouldn’t be happening”, certainly. Your machine ought to be coping.

Check Activity Monitor (in /Applications/Utilities/ ), and see what’s using CPU and RAM.

Hmm. Those CPU figured are very high.

For comparison, I have Dorico on 18% and VST on 74% while playing back a piece with over 20 Players and 30 Flows using NotePerformer and other VSTs on a 6-core i5 Mini (2018).

My buffer size is 256 samples. (Edit > Device Setup > Device Control Panel). Other than that, try re-applying the Playback template. Is there anything non-standard about your audio setup?

I set buffer from 256 to 512 samples, let’s see if it makes any difference.

The most “non-standard” would be my old MOTU audio device, FireWire via two adapters to USB-C…

Maybe try it without?

Create a Diagnostic Report and post it here: I’m sure one of the team (probably @Ulf ) will be able to work out what’s going wrong.

What is strange in my eyes, that Dorico itself is using up so much cpu power compared to the audio engine. The figures should be the other way round. Do you have condensing switched on?

Thanks! But the high CPU usage on Dorico hasn’t anything to do with the MOTU I’d guess…?

No, Condensing is set ‘off’

Dorico (537.3 KB)

The only things I’ve modified is a couple of playback issues:

Changed the length of ‘default note’ value from 85 to 99% length, both in Playback options and in the expression map of NotePerformer (Playback overrides). I know NotePerformer recommends 85% but it sounds very short on most notes.

Thanks for the data, but when it comes to performance the log data does not show very much. Maybe we could have a remote screen sharing session at some stage.

That’s very generous, thank You, just tell me when! Maybe I can call you up on Zoom and share screen?

This is how it looks in Activity control panel when Dorico “crashes”. ( It doesn’t really crash, rather “hangs” )

I dont haave time now, I’ll send you a PM later.

Certainly :slight_smile:

It is not an official and supported solution, but if you don’t use video in Dorico, you could completely remove the videoengine.bundle from the Dorico application, since it is known that this engine causes a lot of cpu load, even if your project contains no video at all. See this post from Ulf:

In my case it makes a big difference, the first screenshot is from playing back a project with the unmodified Dorico application and the second screenshot playing back the same project but with removed videoenginge.bundle: