System Requirements: Mac OS X High Sierra

Is Mac OS X High Sierra mandatory?
Because I have a Mac Pro 3.1 Early 2008 with Mac OS X Sierra and I can’t update to High Sierra…

Yes, WaveLab won’t install on 10.12 or below.
Blame Apple, not me :unamused:

:frowning:

Thank you :cry:

High Sierra here on Mac Pro 3.1 8-core machine :wink:


high sierra.png

Urgh - bought the upgrade in a fit of excitement without checking the HS requirement (still on 10.12.6). I will upgrade now, just for you PG, thats how much I love Wavelab!

just for you PG, thats how much I love Wavelab!

:slight_smile:

<3 <3 <3