System spacing won't reset

Panic time. I’m trying to get these parts out on deadline and cannot get this item to reset.

Everything I try moves it further and further from the system, including Undo and Reset position. Help!

Have you tried cutting and pasting everything in those few bars?

You mean go to full score, select everything, cut and paste?


Thanks for the suggestion. I tried it and it didn’t totally fix the oddity. It *did put the tempo mark about 3 inches lower (probably due to the many manual edits I had attempted). I reset its position, but then the fun started again.

EDIT: I worked around it somewhat… After pianoleo’s suggestion to cut-paste, the result was odd but acceptable. I respaced the other staves manually and it’ll be ok to distribute. But I’m afraid to touch it now. Would still like to get to the bottom of this!

Otherwise try resetting that tempo marking’s X and Y offsets, then cutting and pasting just that one object. Worst case scenario delete and re-enter that marking.
It’s sometimes worth fooling Dorico into re-casting those few bars with some additional system breaks, then removing the system breaks.

Whatever you do, don’t panic - there’s always a way around these little glitches.

Oh, and search in future - I’m not saying anything here that hasn’t been said before. (I have a reputation to uphold, after all :wink:)

pianoleo, I do appreciate the additional suggestions, but they unfortunately didn’t work. Any edits to any parts and the problem returned in that particular part (Flute 1 only, for some reason).

In the end, I deleted both the tempo mark and the rehearsal mark, and added both to the bar where the rehearsal mark was. It’s actually changing the score, but it’s acceptable, and I don’t have any more time to monkey (or to search the forum further, which I indeed did attempt).

Two days ago (and a few times earlier too) I had several times exactly the same thing.
It is really annoyous and I would really like to understand what is triggering this behaviour!
But I found out that applying any edit to the “Vertical Spacing / Inter-system gap” in Layout Options did reset the position of the “moving item” and the system spacing.
Maybe it works on your system too.

Personally, I have a sneaking suspicion it has to do with the rehearsal markings. Dorico wants to add way to much space for them by default in any score that I’ve ever used them.

Partially. I’ve noticed this behavior particularly when a tempo marking comes just BEFORE a rehearsal mark, and close enough that Dorico needs to activate collision avoidance.

When the rehearsal mark and the tempo mark occur at the same beat location, Dorico puts the rehearsal mark first, and all is well. At least every time I’ve seen it.


Following as well. I’ve had several issues of text moving up and up and up, and nothing seems to reset it to the original position (UNDO, RESET, etc).

This looks to me like a bug similar to several that we’ve seen before. The way that Dorico’s collision avoidance system works is designed to be very accurate, but we have had problems from time to time with the amount of space Dorico initially setting up for an item then differing by tiny, fractional amounts when it comes to adjust the considerations for collision avoidance in a later edit, and this tends to cause tiny left-over pieces of collision avoidance data to remain behind, and this in turn can cause the staff spacing to become unstable.

Dan, we’ll need to see the specific project in order to diagnose the problem. I imagine that if you export only that one layout from the project it will still exhibit the behaviour, so try that (and then reset the playback template to e.g. ‘Silence’ to reduce the file size), and attach it here.

By the way, you should now be able to attach a Dorico project without first zipping it up (in common with other attachments, provided it’s smaller than 2MB in size). Give it a try and see if it works!

Attached. I had removed it entirely, but I put it back for the purpose of diagnosing, and the behavior returned.

Flute 1, rehearsal G. Thank you Daniel.

PS: Not able to upload the Dorico file without the zip function. The “Open” dialog didn’t show the file as an option until I zipped it.
When You Were (657 KB)

Thanks, Dan. We’ll look into this and try to get it sorted before the next update.

As a workaround for the time being, if you make the 2-bar multi-bar rest before G a bit wider using the Note Spacing tool, you should find that a couple of nudges of Ctrl+Alt+right arrow is enough to clear the interaction between the tempo and the rehearsal mark.


Dan, considering your pedigree, I had to check a certain other notation problem for its defaults.
I don’t use chords that much but was interested in what I found.


Wrong thread, but yeah, it seems my format is the oddball here. Not sure how I decided sus7 was the right notation years ago. Ah well…

Oh my. I just realized that, for 20 years, I always had thought Finale just didn’t know what a sus-7 chord was. I always had to add the chord suffix myself. Palm to the face.

Hi, I said I would bump this thread as I think the question is relevant to the spacing adjustments instead of starting a new thread. I am new to the software but so far am loving it. In this score (image attached) I am using a lot of text above the staff for the parameters of the synthesiser part and am running into wild staff spacing jumping around issues. When they jump the text objects jump too and stay there, even if I undo (sometimes). I am inputting the music and text and immediately adjusting everything in Engrave mode. Maybe this is just a habit from other software, straight away adjusting everything into place. Should I actually try just input everything first and engrave later? I think it is especially difficult because I am using fonts for arrows as there is no line tool yet. And these long text objects tend to be collision heavy. I have turned off automatic vertical adjustment and played with the no collision function but am struggling to keep everything in place as I progress. There is probably something obvious I am missing.

Thanks in advance!
Screenshot 2019-03-08 at 22.11.03.png