System Timestamp not helping with early MIDI notes

I’ve been experiencing this issue where the timing of recorded MIDI would always be earlier. For a long time, I thought it was just my incompetence as a keyboard player, but more and more I couldn’t shake the feeling it didn’t sound that bad while I recorded it. (I never have AutoQuantize enabled)

Turns out, it’s not necessarily a Cubase issue, but an issue with MIDI drivers on Windows. I researched for answers and found a good deal of articles on the subject, most of them said to experiment with the ‘use System Timestamp’, as well as other stuff like enabling emulated DirectMusic ports as mentioned in this article.

But nothing works! Messing with these things changed nothing for me. Unless I need to restart Cubase every time I change these settings, that’s about the only thing I have yet to try. Another possibility is trying a different controller, but I have no means of doing that at the moment.

I also tried messing with latency settings, both in Cubase’s settings and in my interface’s buffer size, etc. It’s not a latency problem, when monitoring the notes aren’t delayed, but once I view and playback the MIDI part I just recorded, the events are early.

I’m on Windows 10 x64, I have an Apollo Twin mkII (thunderbolt), my controller at the moment is an Ableton Push 2 (used with this very neat little software and loopMIDI), running it at 44.1KHz.

This has happened to me for years. And on different PCs and Windows versions using different Cubase versions. Even with different audio interfaces. But, for me it happens only when using certain VST instruments on instrument tracks. Since the timing offset is always the same on these particular VST/instrument tracks, my workaround is to save my templates that include these VSTi/instrument track combinations with a track offset set to -62 ms.

Done… but… weird for sure.

For me, this workaround is sufficient but, I will be following this topic to see if anyone else knows an actual “fix”.

Regards :sunglasses:

My issue with that workaround is that it makes the notes SOUND on time, but they still look the way they were. Which makes editing harder/more cumbersome than it should be. Ideally, there’d be a MIDI recording offset in the options, like for audio under Studio Setup… and how S1 has.

Agreed on all points. :wink:

Regards :sunglasses:

I think I found the solution. Please confirm if this works for you

In Preferences->Record->Midi, turn on Add Latency to MIDI-Thru Processing and ASIO Latency Compensation Active by Default

You can turn ASIO Latency Compensation off and on for individual tracks in the project window, but the setting is not visible by default. It seems like it has to be on for this issue to be resolved. I had it on previously, but Add Latency to MIDI-Thru Processing was the missing piece.


Descriptions from the manual:

ASIO Latency Compensation Active by Default
Determines the initial state of the ASIO Latency Compensation button in the track list for MIDI or instrument tracks.

If you record live on a VST instrument, you usually compensate the latency of your audio card by playing too early. In consequence, the timestamps are recorded too early. By activating this option, all recorded events are moved by the current latency, and playback sounds like during the recording situation.

Add Latency to MIDI-Thru Processing
If you set the audio buffer size to a high value, and you play an arpeggiator in real time, for example, the MIDI notes are output with an increased latency.

If you consequently adapt your playing to the output latency, the notes are recorded even later. To minimize this effect, you can activate Add Latency to MIDI-Thru Processing. This adds a regular latency to each note that is played in real time.

I had previously given up on fixing this and just assumed that my timing was off (I’m not a performer). Seeing this thread made me start searching again. In some thread about this issue (I forget where) I found a great testing method that helped me confirm that my timing wasn’t the problem:
Set up an instrument track, an audio track, and a group track. Instrument track should output to the group track. Select the group track as the input for the audio track. Now if you record enable instrument and audio, you will record midi notes and audio output at the same time and you can visually inspect them to check recording timing.

Before the fix, the midi notes were ahead of the audio notes for me. I messed with various settings until I found the combo that made the notes sync up.

After further testing, my “solution” appears to make notes a little less early if my ASIO driver is set to a large buffer size (512), but it doesn’t fix the problem completely. At the small buffer sizes that I normally use (16 and 32), it doesn’t seem to make much difference

The dual midi/audio recording test does allow me to measure the exact time difference (.026 seconds consistently it seems) and correct the midi recording

I’ve tried messing with those options, it only seemed to make it worse. Maybe I didn’t try that combination though, will try again and get back here.

‘Timely’ for me as well.
I’ve messed around with these settings as well. I’m on C9 with a UR824 interface & MOTU Microlite for outboard gear.
Main controller is a Nektar T6 via USB midi.
My issues are early midi, still haven’t quite figured it out. Recently upgraded from Cubase 6.5, and don’t remember the timing being this off.

For the longest time, I thought I was the only one seeing this “MIDI-NOTES-RECORDING-EARLY” issue.
Now, I’m seeing posts in forums all over the place.
I’m also seeing the exact same problem in Cakewalk Sonar (64bit) and I’m thinking this all started when I upgraded to Windows 64 BIT.

Steinberg and Cakewalk both seem to be surprised whenever someone brings it up… as if it’s never been brought up before.

Before they closed doors (before Bandlab took over) a rep at Cakewalk whispered that he knew it was an issue and there were people looking at it but they never got to it and closed shop.

Now, Steinberg: Same exact issue. They appear to be scratching their heads.
I’m hoping they take this seriously. I mean… MIDI is their thing right? They MUST see this as an issue. How hard could it be to throw in an option to compensate for this problem that many are having?

I’m glad others have done the simultaneous Audio and Midi test. You can clearly see the MIDI notes planting early. Hello, I can see it just by looking at the midi scroll while I’m playing. the notes are clearly painting onto the timelines too early.

I hope someone comes up with a fix soon. It’s been making all of my sessions frustrating.


I’m happy I found this thread. I’ve had this timing issue with Cubase 5.5.3 for years and never was able to find a solution. I’ve searched many forums and contacted Steinberg support twice but never received any answer on this. Such a shame!

If I remember right, this issue started when I moved to 64 bit Windows. I don’t recall having this problems with 32 bit Windows back in the day, but maybe because I used an Audio Interface with integrated MIDI port. Now I work on Apollo Firewire with no MIDI, so I’m using a Midi Interface from Roland (UM-1). I’ve tried all options I know and it seems like it’s working (with the “Use System Timestamp” settin ON), but only after a Cubase fresh start, then after a few minutes timing goes crazy again. I’m no expert, but I feel like it has something to do with the CPU performance. Maybe there is a setting in Bios for CPU?!?

Yes; I agree. This issue did begin when everyone switched yo 64bit.

I’m surprised that Steinberg responds to us with “never heard of this issue before.” It’s clear from so many forum posts, going back years, that they have heard of it before.

My most recent exchange included links to all of these forums showing clear evidence that this issue is real, it’s not new and needs a fix.

Weeks ago the response I received was that the rep was going to pass the issue onto the developers…

Black hole. No fix.

I wish I could find a good workaround.

I hope 11 brings some fresh ideas into this crippling situation. I read articles(SOS) and forum about this and looks like theres a lot to try on windows side, but i have early notes on mac too. Nothing casual (preferences/buffers/latency compensation) works.

Just curious, folks mention Sonar and S1 here having the same issue. I have only Reason to compare and it´s perfectly fine. Is it tied to more some daws and others less/not (i know every system acts little bit of its own way).