Systems more 'compressed' in one page only for no apparent reason

One of my flows is engraved with 2 systems per page (Dorico’s – reasonable – choice, I didn’t try to enforce it). Everything looks fine save for one page where the systems are kind of ‘compressed’:

I can try to fiddle with this manually but I’d like to understand what’s going on and how to avoid this in the future. What could be the cause of this and how to prevent such a behaviour? There are no system breaks in the vicinity; the whole flow contains just a single system break at the very end.

Thanks in advance!

Hi Elwro.
As I think I’ve written twice or more in the last 24h, you should check out John Barron’s latest Discover Dorico to master vertical justification. Learning Leading Layouts
That page has a “system justification” while the other pages are on a “staff justification”. Changing the thresholds very slightly will give you the result you want. It’s really worth the while to learn that stuff :wink:

2 Likes

I’m not sure that’s just a lack of vertical justification, as the top staff of the top system is also lower on the page.

Does this page have a red triangle override when you check in the right panel in Engrave mode? Have you overridden the music frame padding on this page? Are there definitely no red handles when you select Staff Spacing in the Engrave toolbox?

If none of the above, share the project here in this thread. If you apply the Silence playback template first, the file size should be smaller.

4 Likes

Thank you very much, @Lillie_Harris and @MarcLarcher ,for your suggestions.

So: no red triangle override, no override of the music frame padding. However, there were two red handles on the two systems. When I deleted them, the systems spread out with a big gap, since the page was 81.x% full and I was using the default threshold of 80% for ‘system justification only’. I changed it to 82% and the page now looks great.

So initially system justification does not seem to have kicked in, due to the mysterious system overrides. I swear to the Almighty I have not consciously done anything toward setting them :slight_smile: Would you have any idea on what could have created them? I’m attaching the project.
Harrer_SinfoniaF_a8_backup.dorico (724.4 KB)

@MarcLarcher , thank you very much for the video suggestion, I’ve watched the ‘vertical justification’ section, it didn’t work exactly like that in my case :slight_smile: and when thinking why that was, I discovered the system overrides, after removing which the project started behaving like the one in the video.

Incidentally: why aren’t vertical justification options flow-relative? Here I have just a short, 3-movement Sinfonia, but in bigger pieces I’d be wary that changing this option for one flow might have unintended consequences for some other flow…

Thank you again!

1 Like

Moving staves or systems around will do it :wink: Generally these overrides get lost if the page number they originally occurred on changes, but there are circumstances in which they can be retained. It’s possible you moved staves earlier on, then added more music or something so the overrides ended up applying to the wrong music? It’s generally best to avoid moving individual staves/systems unless it’s really necessary, and then best to wait until the end of the writing process.

2 Likes

I agree that it should be possible to have “vertical spacing changes” at different points in the music, just as you can have note spacing changes at the moment. It’s not something that’s possible at the moment, but it is something we plan to implement in future.

5 Likes