Systems on *one* page suddenly eliding

I’ve spent many hours on a score that’s still a work in progress. I appreciate the hard work that’s gone into making Dorico smart, such that many features are automatic. Unfortunately I’ve discovered that suddenly, on one page, the two systems have elided.

I have no idea how this could have occurred. So far, I’ve only been editing key signatures, notes, articulations, and rehearsal markings. I haven’t touched any settings for staff or system spacing (and wouldn’t even know where they’re located). I just looked up, and this one page was askew. Dorico typically handles spacing automatically, so I’m surprised by this.

The attached screenshot shows the problem on the left, and a normal page on the right.

Any suggestions?

Have you tried to close and restart Dorico? Sometimes this cures strange behaviours.

I’ve seen this happen as well. Restarting did not fix it for me.

Thanks for the suggestion. It was worth a try, but unfortunately restarting Dorico did not correct the problem.

So, what’s the best way to address this manually?

Could you post the project so we can take a look?

OK. I’ve discovered the culprit:

In another thread (https://www.steinberg.net/forums/viewtopic.php?p=763812), I inquired about inserting jazz “fall” markings. Per the instructions given in that thread, I copied the Bravura symbol and used Shift X to insert it multiple times in my score. (In the screenshot I attached, you can see the fall markings on the leftmost chord above the red box.

Unfortunately, when inserting one of those characters, Dorico places it far above the selected note. Then I have to switch to Engrave mode to grab the marking and drag it down beside the note. Apparently, when these markings are first inserted, Dorico adds vertical space to make room for them—above the note—but even when the marks are relocated to a lower position, Dorico does NOT remove that extra vertical space.

This wasn’t a problem in the treble staff, but when I added them to the bass staff, that extra vertical space that Dorico adds caused the systems to elide. (I simply didn’t notice it yesterday.)

So…

  1. It seems Dorico needs to be made to understand that if music-text markings are moved from their initial, vertical position, it can remove the unnecessary vertical space that it adds. Obviously that will require a coding update.

  2. In the meantime, since there’s no other way for me to add these jazz articulations, is there a way to override Dorico’s automatic vertical spacing on one page?

EDIT: It’s cumulative. so, each time I add a fall mark, Dorico adds more vertical space. By removing all but one mark, the spacing is back to normal—but I need the marks. So, I still need a solution to this problem.

You should find that Dorico removes the unnecessary space if you select the text objects and switch on the ‘Avoid collisions’ property (only available in Engrave Mode) but leave the checkbox unticked.

When you create such text objects by copying glyphs from the SMUFL site, make sure you use the font Bravura Text and not Bravura. The lineheight of Bravura Text is smaller and thus more suitable for text objects.

Yes! Thanks!

Thanks. I used the characters that Daniel recommended (https://w3c.github.io/smufl/gitbook/tables/brass-techniques.html), so I assume they’re the correct ones. :slight_smile:

You need to double-check that the font really is Bravura Text and not Bravura. If you copy and paste the characters, there’s no guarantee that the correct font will be chosen automatically: you must choose it yourself.

But Dorico will still leave some extra space between the staves, even if the text elements are moved onto the stave. Therefore one has to switch off ‘Avoid collisions’. Are there any plans to change this?

I don’t know what more we would change. You can choose whether text should avoid collisions or not by default, and override it on a per-item basis. That seems reasonably flexible to me.

I do want Dorico to avoid collisions for text, but I don’t want Dorico to avoid collissions for elements I have to enter as text at the moment, for e.g. Breath marks:
https://www.steinberg.net/forums/viewtopic.php?f=246&t=102830

At the moment it is quite a lot of extra work to position the breath marks, switch off the collison avoidance and sometimes move the notes further apart.
Perhaps in the future there will be only a few items (or none?) I have to enter as text and than move it onto the system, so that I don’t mind this behaviour anymore.

Thanks for the reply, but respectfully, this is unclear. You posted a link to a page full of characters, and I selected a character from that page. Now you’re saying we “need to double-check that the font really is Bravura Text.” Did you not link to a page with the correct characters that we should use?

You’re misunderstanding. The page you’re copying from is correct; the characters you’re copying are correct. Unfortunately a clipboard action (pasting) has no control whatsoever over what font you paste into. You need to check that the font you’re pasting into (when you invoke the Shift-X popover) is correct, yourself. No website, whether smufl.org, Steinberg.net or any other, can take control of that for you.

Thank you. The part about checking the font "when you invoke the Shift-X popover" was not stated before now. Now this makes sense.

The advice provided in this forum is invaluable. But posts are sometimes are hard to follow because details that seem obvious to Dorico veterans are far from obvious to newcomers.

Thanks again for that clarification. :slight_smile:

Dear soundsgod,
My apologies for the previous post, I admit I could have been more clear in the explanation… I was walking in the country and answered from my phone, hoping you would find easily the options I was referring to in the properties panel :wink: