Systems won't justify without introducing collisions

I’m having trouble with justification options in Dorico 5. When I have ‘Automatically resolve collisions between adjacent staves’ ticked, the staves on the right-hand page won’t justify, and conversely, when the option is unticked the staves justify but this results in collisions in the dynamics. Am I misunderstanding how these layout options work somehow? This is happening across the board, not only on these two pages.


We need to see:

The % Fullness for these pages, shown in Engrave mode.
The % Justification values in Layout Options
The values for Minimum Gaps.

Also: have you moved (in Engrave mode) the dyanmics and colliding items from their default positions?

%Fullness for the two pages attached
%Justification values and Minimum Gaps also attached

I’ve changed these multiple times trying to find the magic combination, but can’t quite solve the puzzle. I can’t remember if I have manually adjusted any dynamics on these pages in engrave mode - is there a way to check for that? Thanks for you help!


They will have Position offset properties set in Engrave mode.

Having both percentages at the same value means that the second one always wins. So any system over 80% will only add space between the systems. Here’s my handy guide to how they work:

Toggling the Resolve Collision button probably tips the page the other side of the threshold.

In general, I’d suggest that you want to do less. So I would let Dorico resolve collisions, and then only fix manually what can’t be fixed globally with options.

Interesting. What fixed it was switching to 50%/100% (apply), as you said, then toggling off Resolve Collision (apply), then toggling Resolve Collision back on (apply), then switching back to 70%/100%. I had tried 70%/100% before and it didn’t work, but apparently this was just the magic sequence. Thank you for your help, I appreciate it!