Tab not appearing entirely and db levels not working

Hi,
I am trying to decrease the overall volume of the organ, but the tab doesn’t appear completely on my screen, so I don’t know if I am missing some kind of “ok” button.
In practice, after I change the db level and go back to the score, it automatically resets to -4.2 so my changes do not apply.
What should I do?

I would suggest setting the base volume for HALion instruments in the Dorico Mixer rather than the HALion Mixer.

mixer

Ok thanks. What about the tab not appearing entirely?

Do you have the option of increasing the display scaling of your main display so that items on it appear a little smaller?

So I didn’t do anything and now the tab is appearing entirely.
That said, changing the volume level through Halion’s mix still doesn’t work (but on Dorico mix or on the Halion’s edit instrument it works).

That’s because the HALion mixer is (I suspect) like the Garritran Aria mixer and reflects dynamics written into the score, whereas the Dorico mixer (like the Finale mixer) sets base levels and remains constant.

Actually on one laptop the tab is normal but not on another. However, decreasing the display scaling worked.