Take Four?

Hmmm, something fishy going on here Dorico…

When inserting time signatures Dorico automatically rebars as far as the next existing time signature. If you want it to insert time, you need to turn on Insert mode before adding the new time signature.

My suspicion is that the 4/4 was already in place at the point at which you added the 5/4.

You can fix it retrospectively by selecting something at the rhythmic position where you want to insert the extra heat and then typing Shift-B 1q Enter.

(Or just re-input the 5/4 time signature, this time with Insert mode active.)


In some other programs it makes sense to add the following 4/4 before adding the preceding 5/4, or else one runs the risk of tie chains being irrevocably rewritten downstream. Dorico handles tie chains more flexibly, so this isn’t an issue. You can pretty safely add time signatures from left to right.

Thanks Lillie and Pianoleo, Lillie’s solution worked for me. I work quite a bit in non 4/4 time signatures but I don’t recall that happening before.For this piece I imported an xml file and the time signatures had already been generated in Cubase so maybe something happened in the conversion? It was fine in Cubase.

It would be really useful if Dorico could have a signpost to mark bars with the incorrect number of beats. It could even be off by default, but in music with lots of meter changes, it would be great to turn on and make sure all bars are complete. In Finale, once I’m done inputting one of my first proofing steps is to run Check Region for Durations. Turning on a signpost to alert the user of any bars where the number of beats doesn’t match the time signature would be a valuable aid when proofreading.