Talkback via footswitch?

Howdy all, apologies if this has been answered previously, I have searched but not found a definitive answer. I recently watched a Club Cubase video on YouTube (I think it was June 2014) where the narrator stated that he had set up his control room talkback to be activated by a footswitch. I don’t know what type of footswitch he used but can anyone advise on how to set this up? It would be much more convenient than using the mouse. I know that a keyboard key command can be assigned but for me the footswitch option would be so much better especially if it was non latching.

Hi Riddim

One way would be to use Bome’s midi translator which will change any midi command into a keystroke, I use it mostly live but it would work. Change a second piano sustain pedal (assuming the first one’s doing the piano:-)press into a T for instance (or whatever KC is assigned to talkback!)I don’t know if there is a way to do this within Cubase, some of the other clever peeps here might know.

Best Regards

Dave

You would use the Generic Remote

Hi Dave & Steve,
Many thanks for your replies. I Just had a look at Bome’s Midi Translator. I’d never heard of it before but it looks as if that could do the job.

I don’t know much about the Generic Remote feature either so I’ll read up on that. If I used the GR function to operate the talkback via my sustain pedal connected to my midi controller keyboard (which is a Novation Impulse 49), does that mean that I would lose the sustain function on the keyboard ?

Thanks again for your advice guys

Riddim

Yes, it can only have one function assigned at a time. It would be beneficial to have a look at the manual regarding the Remote. It can be as simple or as complex as you want. (note- remember use the export function to save your remote.)

Dave- Is there some advantage that I’m not seeing to using an external program for this?

If you have a spare sustain pedal (or are willing to purchase one :wink: ), and also have a spare USB input on your computer, then, there exists this converter (yes, I know, I’m great at spending other people’s money! :stuck_out_tongue: )

http://www.sonicstate.com/news/2013/10/02/-connect-expression-and-sustain-pedals-to-your-daw/

While we’re on the subject of spending Riddims money, here’s another idea :wink:

Logidy UMI3 http://www.logidy.com/?pid=1

Very neat! (and probably works out cheaper to buy than a pedal + the Audio Front device)

Looks neat indeed. I have the audiofront device and use it as an expression pedal. It’s great. $50 plus an old volume pedal I had lying around.

http://www.bestbuy.com/site/unitech-usb-keypad-black-black/1306582597.p?id=mp1306582597&skuId=1306582597&st=categoryid$pcmcat251600050012&cp=1&lp=7#tab=buyingOptions

Hi, I saw in your signature that you own a Novation Controller. You have automap. You could connect a footswitch to the Novation Controller and send a key-command to cubase via automap.

Of course with a midi Switch you can also Trigger a generic remote doing what you intend to do.

My main Statement: You have everything you Need. Nothing to buy or add :wink:

Cheers, Ernst

Howdy all,

Thanks for all of your replies, I really appreciated the advice. Looks like there are many options available to me. The ones that appeal to me (because they’re free & immediately available) are:

  1. Generic Remote
  2. Automap 4
    I decided to try GR first…without success so far. I’ve read the relevant section from the manual and thought I understood it. After several attempts it’s not working so I’ve obviously made a mistake/s somewhere along the line. I’ve connected an old (normally open) footswitch to the sustain jack on my impulse 49. On pressing the switch, the midi activity indicator in the transport panel shows activity. I then configured the GR editor as in the picture below.
    Generic remote 2.jpg
    Is there something obvious that I’ve missed?

Many thanks,

Riddim

Strange… the Generic Remote looks fine to me (tried it myself, and it works here).
I presume you are certain that your sustain pedal is actually transmitting CC#64 on channel #1?
I don’t suppose it could be in conflict with AutoMap? (just to test, set the input of all the other Remote Devices to “Not Connected”)

Hi vic_france,

In reply to your question…

I presume you are certain that your sustain pedal is actually transmitting CC#64 on channel #1?

I also assume that these settings are correct. I obtained them by clicking the “Learn” button and then operating the pedal. Cubase automatically populated GR with those settings.

I don’t suppose it could be in conflict with AutoMap? (just to test, set the input of all the other Remote Devices to “Not Connected”)

I will give this a try and report back.

Thank you for your advice.

Riddim

…I’m back :unamused:

I don’t suppose it could be in conflict with AutoMap? (just to test, set the input of all the other Remote Devices to “Not Connected”)

I will give this a try and report back.

I tried Vic_france’s suggestion and it makes no difference to the talkback.

I thought I would try shutting Cubase down and opening it up again. After doing this I found that the settings that I had made, applied, and OK’d in GR had gone. I tried this 3 times, even though my attempts to set this talkback function has failed, the GR settings that I’m making are not retained by Cubase on shut down.

I’m at a loss :confused:

One of the (many) quirks with the Generic Remote, is that, to actually Save your settings, you have to Export them first (yes, I know it doesn’t make sense, but that’s just the way it is). No need to re-import the settings (unless you need to for some other reason)… once Exported, the settings remain.

However, I have no idea why it still isn’t working, sorry.

Hi vic_france,

Thanks again for your reply.

One of the (many) quirks with the Generic Remote, is that, to actually Save your settings, you have to Export them first (yes, I know it doesn’t make sense, but that’s just the way it is).

Huh :open_mouth: ok, noted thanks.

I’m getting somewhere with my original problem…somewhat.
On scrolling through the list of GR commands, I found that CC#64 is already allocated to a track mute function, so when I was operating the pedal, it was actually muting a track. I just didn’t see it because the track in question was scrolled out of the mixer window. I’m surprised Cubase accepts duplicate CC event numbers.
I plugged the pedal into the expression Jack on my controller, set GR to learn and it came up with CC#11. No other function is allocated to CC#11 that I can see. After going through the set up again, the pedal is now activating the talkback function :sunglasses: . My only issues now are:
1: The function latches (I was hoping it wouldn’t)
2: On de-activation, Cubase seems to be receiving 3 signal pulses making the talkback flicker on & off before finally going off (this maybe an issue with my pedals, although I’ve tried 2 with the same result)

At least I’m making headway now…I’ve learnt a lot today!

Ignorance is a terrible thing :blush:

Thanks for your help & advice

R

  1. The Flag column chooses button function.

  2. Choose the specific MIDI device, not All.

Hi there Gump,

  1. The Flag column chooses button function.

  2. Choose the specific MIDI device, not All.

I tried both of your suggestions.

  1. As soon as I select “command” in the device column, the flag automatically defaults to “P” (push button). I think that’s the setting that I need, but even if it wasn’t, I don’t see an option to change that setting.

  2. I selected my actual controller but it hasn’t made any difference.

The function seems to latch/not latch erratically, maybe because of these 3 pulses of midi activity that I can see when I release the pedal.

It seemed like this would be quite easy to set up but I must admit, I’m finding this very frustrating.

I have complained to Steinberg about this more than once. The Flag options are not available when the Device is set to “Command”… so frustrating, when we can see that we can switch off the option “Toggle”, for the other device types.