Tascam Us-2x2hr not taking Cubasis LE out of demo mode

Hi There!

Recently bought a Tascam US-2x2HR, came with the Cubase / Cubasis bundle. Installed Cubase on my laptop, registered it online, no issues. The Tascam connects just fine. Not so much with my iPad, however. 7th gen, running up-to-date iOS. The Cubasis page suggests I can unlock the software by connecting a compatible device, my Tascam is on the list. I am using a Lightning to USB-C adapter cable to do so, with the external power supply, but the app doesn’t recognize the device and still prompts me to connect something via bluetooth or buy the software.

What am I missing? Do I need to enter the same code I used for Cubase somewhere first for Cubasis? Wouldn’t the Steinberg content manager application have that information already?

Hi @CathSaigh,

Thank you for your message and welcome to the Cubasis forum!

Normally, Cubasis LE unlocks from demo mode, when being connected with a supported hardware.

In this regard, we suggest to use original Apple cables/adpaters, to connect your audio hardware with the iPad deivce in use.

When Cubasis LE is launched for the first time, the application asks for the permission to use the devices’ microphone, which has to be confirmed.

Please double check that the option is enabled via these steps:
(1) Please go to the “iPad Settings”
(2) Under “Privacy”, please make sure “Microphone” is enabled.

Please let me know if this helps to solve the unlock topic.

Best wishes,
Lars

Thank you so much! I will try an actual Apple cable rather than a 3rd party next and see if it makes a difference.

Hi @CathSaigh,

Thanks for your message.
Please keep us updated about your outcome!

Thanks
Lars