Technique (pizzicato) not sticking

I have two violin parts that divide. For some reason, during a pizzicato section one of them switches to arco. Nothing I have done seems to affect it. The voices are correct, no MIDI instructions. Worse if I select only one set of violins (still two staves) the error doesn’t occur–but it does if other instruments are played back with it.

Brian Monroe
5.02, Windows 10, 8 core AMD,

Try deleting the pizz on that part and then re-applying it, making sure you attach it only to one note.

(Attaching it to more than one note, even by accident) makes the Articulation “directional,” which means it cuts off when reaching the end of its “selection” rather than waiting for an arco.)

Deleting and restoring has no effect.

As @Derrek says, the problem will be that the pizz. instruction has a duration: try selecting it and typing Shift+Alt+left arrow repeatedly.

So far repeated instructions (which is I’m assuming what I would be doing i.e. pasting/copying pizz markings) are ignored. When I have divisi a3 - voice 1 and 2 play the pizz but 3 doesn’t. If I then go to divis a2 - 2 plays the note as arco. Very strange. I will try again.

I got it to work by disabling the “independent voice playback” option - which gets annoying because I have several sections where the voices use different techniques at the same time. I will still try the other option to see if that works.

I see what the alt shift does - I’m definitely going to try that again. What fooled me was that the score has been revised several times and originally it automatically put in the “directional” rather than “durational” line (extending the span so to speak). However, it is not consistent in the document - thus I will go back through and clean those up and see if I can get everything to work normally. I will let you know.

Unfortunately, adjusting the selection (using shift alt right arrow) does not always work - sometimes it does but not consistently. The only sure solution is to turn off the independent voices - and then go back and adjust the section fields.

This is a long time issue. What you need to do is after creating the divisi, go into the mixer and enable IVP.

Also, how are your ‘div’ markings created? This is an issue with (IMO) how Dorico’s default playing techniques are setup. Newly created playing techniques have the playback set to “Natural”. This KILLS THE PIZZ. On strings “nat” means arco.

So what you need to do is create a new effect (I call mine “nothing”) which as opposed to “Natural” is a true no-op that doesn’t set any CCs, etc.
Screenshot 2023-07-19 at 3.01.10 AM


Could you elaborate a little bit more on how you apply this new technique in this context specifically? And what do you do with the original “Natural”?

I have an issue where Dorico 5 (not any earlier version) is sounding voices in IVP that are not supposed to be playing at all, resulting in a “Natural” playing on top of, say, “spiccato” and it’s just insane.

I use note performer 4.x (although Halion is doing the same thing). I always enable the independent voice when setting up the score. Then the divisi sections are created using the “change divisi” option.

For right now, I have the independent voice switched off from the start. That seems to help - but not always. Part of the problem is that many of my scores were created in prior versions of Dorico and I think some legacy code might be caught in the conversion process - (since it happens automatically when you open an older version file in a new version). That might explain the inconsistency on the pizz selection (only one note is selected by default as opposed to the passage) but no matter. Still have to work on it. - I will try the solution you proposed and see how that works.

Added later: The “nat” designation never appears on the staff - but I’m still going to try your solution.

Interesting results.
First attempt: turned off independent voice used new technique suggestion. No problems at all.

Second attempt: turn on independent voice and used new technique suggestion. This was a disaster - once again inconsistent response. It might have to do with what happens when you change divisi - the voices change on both lines - perhaps that has something to do with it?

At any rate it looks like we’ll have to do without independent voice - although if I were to completely write a new file it probably would work fine. At any rate this is an acceptable solution for now. Thank you for your suggestions.

I’m having this same problem now. I’ve placed “pizz” over just the first note of a phrase. Then I copy just the phrase to repeat it, and I want the pizz to repeat as well, but it doesn’t–it reverts to arco.
Here’s my Play preferences.

The simple solution (which you have probably already used) is to re-apply the pizz technique to the copied passage.

But one thing to consider is that, if one selects a range of notes and applies a technique like pizz to it, Dorico will revert to arco automatically when the end of the selected range has been reached, whereas if one applies pizz to a single note, it should last until reversed by an arco command.

1 Like

The crazy thing is, Derrek, that even if I re-apply the pizz technique to the copied passage, when I start playback from the first passage, IT STILL REVERTS TO ARCO :neutral_face:
Also, I only applied the pizz technique to the first note, as advised above.

Wow! This vid’s even better! Dorico seems to pizz whenever it likes–hahaha. Checkout bars 53-54!


@Derrek @888Xmuse591

@wrldwdarr we cannot see enough information from a video. please share the Dorico File (a cut-down version that presents the issue) with the steps needed to reproduce the issue, indicating the bars, beats etc.

Here ya go. Just highlight the first bass-note and press “p”.
Erroneous behavior may begin earlier (I’ve had a number of different playbacks where one phrase will spontaneously switch to arco), but Dorico purposely defies an order to pizz in bar 9. Then in the next phrase it’ll heed, followed by a non-heeded pizz order. Note that I specifically added the pizz performance technique to the first note (only) of each of those phrases, thinking it would help and it might be a work-around since I could hide the extra pizz labels (that are unnecessary in standard notation). Where Dorico gets really high is at bar 15. Enjoy!
Pizz on drugs.dorico (1.4 MB)

Hi @wrldwdarr thank you for the file.

I think I managed to solve (mitigate) your issue:

-as @dspreadbury suggested, I selected the pizz. and pressed shift+alt+left arrow many times to be sure that the pizz. has no length

-then I deleted the pizz. signposts

-then I selected all the violin part and deleted all the staccato (with pizz. also I think is not necessary to write pizz.): I think this could give problems because pizz. and staccato are two playing techniques that can collide (?)

But of course is a little strange what happened in your project. maybe someone has a better explanation/solution…

I attach a corrected version (I hope I didn’t miss something):

Pizz on drugs-CORRECTED NO STACCATO.dorico (1.4 MB)


I tried substituting the vn. solo with Iconica sketch violins 1: and also adding the staccato it works very good (I edited my previous corrected example, so the other changes are also there).
So there must be definitely something going on with the Expression Map of HSO were pizz. and staccato collide and gives strange results (maybe because the notes are so fast?..but no idea…).

I noticed, in your initial example if you leave the vst visible in edit view, the articulation switches to legato on every rest, and then in the problematic areas stays on legato, probably because this switches happens too fast and the expression map informations are are too fast for HSO… (just thinking loud)

I attach this version:

Pizz on drugs-CORRECTED iconica sketch and staccati.dorico (1.1 MB)

1 Like