Tempo detect bug since Cubase 9

Tempo detect almost always works, but yesterday it took me for a long ride.

This is also in the forum in Cubase 9 and 10.
What happens is sometimes a full MIDI track off grid, then:
1 Tempo Detect
2. Cursor changes to Warp tool (normal)
3 look at the Tempo track and nothing happens

EDIT: I almost forgot:
Sometimes it looks like it works, and the Detected Tempo is OFF with the detected track!
This is not complex material, just a simple High Hat track or a Kick track!

Work around is I have to split the track into sections, and Tempo Detect them separately.

I usually toggle the track between Musical mode and Linear, and then it works,
which is an easy work around.
However yesterday, nothing worked for a full 1/2 hour, until suddenly it did.

I toggled Tempo Track On and Off, toggled track between Linear and Musical,
I even created an empty project and imported the MIDI track and and Tempo detected it.

Finally, in an empty Project got it to work after the usual endless Toggle,
and it worked. So, back into the full project, and it did not work again.

After endless Toggling all of a sudden there it is again, it worked.

In the Cubase forum the thread title is “Tempo Detect works… until it doesn’t” or something similar.

I hope this bug does not continue again into the new release.
So many bugs, and so long for Steinberg to fix them. Frustrating.