Tempo Detection broken, can anybody help?

Hi all!

I must confess, I’m frustrated. Hence, my question:

Is there anybody, really, who has managed to get Tempo Detection to work reliably and productively?

Here’s what I just tried (again…):

  1. Record a simple, rhythmically clear guitar track.
  2. Run Tempo Detection on this track.
  3. Anytime I want to correct the detected beats while the dialog is still open, it gives one or more of these results:
    a. Doesn’t stick to where I drag it,
    b. Sticks, but doesn’t adjust/recalculate any of the beats coming after, or
    c. Messes up the beats randomly after the attempted edit.

Results seem a bit better with 44.1 than with other sample rates.
I’m at my wit’s end and really disappointed.



Using it occasionally.
Had no such problems with that
And yes it’s not that accurate in detecting beats sometimes :slightly_smiling_face:

In older versions there was some other than 44.1 related issues
Didn’t check it in C11 yet


Here’s a GIF I made of what happens:

Cubase Tempo Detection

This happens with the TD panel open, right after analysis… Would be nice if I could get this to work.

P.S.: I’m on 11.0.41

I’m on 11.0.30
Could you attach a file you are fighting with, please?


Well, I tried the following, reproducible steps:

  1. Start a new, empty project.
  2. Add a tempo track.
  3. Make a tempo change for a dozen beats or so.
  4. Render click between locators.
  5. Then, first disable and then delete the tempo track, the rendered metronome track should now reflect the programmed tempo change.
  6. Run Tempo detection on the rendered metronome and watch what happens when you try to correct the wrong detections…

All the best,

Just repeated these steps and its ok.
Yes, there is no AI logic there
But I was able to reproduce my tempo track in 10-20 mouse clicks
Nothing wrong here for me


Very strange.

So, if you move the beat markers to the proper positions, they stay? Here they snap back and mess up everything after the edit…

Yes. They are
You should try to trash your preferences (rename Cubase 11_64 folder)
I hope this helps


Just reporting that I tried in safe mode, disabling all preferences, and the issue persists. Time to open a support case…