Tempo detection - Only detecting small portion?

I’m using tempo detection on an acoustic guitar part with plenty of clear peaks throughout. It detects only the first 30 secs or so, then it says there is a big change in tempo so it can only detect up to that point? But listening to the track there is no change that I can hear or see on the waveform.

Anyone offer advice please?


Cut the track just before the point it gets lost and then try again on the remainder of the track.
If that fails, map a few bars manually at the cut point and then cut again after the manually mapped bit and try auto on the remainder.


Hey thanks for that quick reply. I’ll give it a shot! :slight_smile: It’s a shame the tempo detect doesn’t look past that part and do the rest regardless. - Steinberg?


. . . why is the tempo detection not that easy as the Samplitude Remix Agent does, stepping towards all neccessary functions:


The tempo detection is still very poor and frustating even in Cubase 6.5, when you have longer audio-files.

Steinberg, your turn? :wink:

Hi Al,

There’re at least two approaches you can try here to get the rest of the tempo detected:

  1. If you are sure that the tempo of your music is rather constant (with minor fluctuations), then you could apply the “smooth tempo” function additionally (can be found in the same tempo D toolbox) right after your first detection (which only delivers up to 30s in your described case). This additional tuning function is only available after your first “Analyze” attempt during the same tempo d session, otherwise the function button is usually grayed out when you open up the toolbox.

  2. The other option is by “pointing” and adjusting the last delivered valid beat to the algorithm immediately right after your detection. You may have noticed that once you have applied the tempo D function, your tool mode is automatically switched to the “time warp” mode, where this TW tool (mouse cursor during this mode) allows you to fine tune your individual detected beat manually to the microscopic level. So, in your case, after the first 30s of the beats are delivered by the detection, you could immediately go to the tempo track and adjust the last valid tempo node a little bit (slightly to the left or right), then you will notice that the algorithm will suggest the rest of the following beats (subsequently their tempo) as soon as your first move is done.

For your case, I would suppose using the first approach should be sufficient enough to get the optimal result, since the second option is more for tackling music with heavily fluctuating tempo, which is not your case. In case you are not familiar with the time warp tool, you could refer to the manual for more information. Hope this helps! :wink:

Good luck,