Tempo Map to Static Tempo

I’m looking for a little help.
I’m preparing a few performance tracks for a band. I import the original recording and create tempo track. I’ve done this many times without issue but now I have one.
As always, I create a tempo track from the original recordings. Once the midi is done, I turn-off the tempo and select a static tempo. But now the problem.
The piano, percussion and a few other tracks conform to bars & beats as expected but a few midi tracks get displace, these don’t conform for bar & beats. Instead the midi performance follows the fluctuating tempo of the original audio.
I turned on & off musical & time linear and still the problem remains.
Please, what am I missing?

I can only imagine that the problem tracks were in Linear Mode while you were editing the tempo track then setting it to a fixed tempo (i.e. the damage was already done).
Is the Project’s Undo History still present?

Thanks Vic,
I may have inadvertently turned on/off musical mode while working. I wrongly thought musical mode is automatically engaged once tempo mode is selected.
So, just to review, I should be fine if I firstly turn on musical mode once I import an audio track.
Many thanks,

That is only the case, while using the TimeWarp Tool directly in the Project window, or on the track(s) that are currently open in the Key/Drum Edit window.