Tempo Matching Songs In Cubase 10 Issue


I know this topic has been addressed many times before but after watching all of the YT videos, I still can’t get it to work.

I’m working on some radio production elements where I need to beat match three songs together and create a mix/mashup.

The first song is 118 BPM, the second 104 BPM and the third is 124 BPM and I want my target tempo in project for all three songs to be 115 BPM.
115 BPM is somewhere in the middle and makes the slower song not sounding to fast as well as the faster ones not sounding to slow and unnatural.

The problem is when I import the first song (118 BPM), analyze the tempo and set definition from tempo, upon importing the second song (104 BPM) and setting it to musical mode, the timing of the second song gets all messed up. The first song follows click and does so no matter what tempo I set, but the second song won’t conform and do the same. Even when it matches the click, it does so for the first few bars and then it goes out of time with the first song and the click. Like being in the musical mode doesn’t really affect it.

Is there a simple way to import full songs all with different BPMs and make them time stretch and adjust to a fixed project tempo?

There are all these options ''set tempo from even’t, ‘set definition from tempo’, ‘stretch to project tempo’ but they don’t really seem to work. One would think something like this would be a one or two click thing instead of navigating through menus going through all these steps in order to set it up.
I spent a day and a half trying to make it work and still can’t figure out which option I should be using and why it’s not working.

This is NOT a real answer but may lead to one . I DO feel your Pain . Tempo matching and stretching and bla bla are tremendously frustrating for me too. I’m sorta learning disabled / stupid though :slight_smile:

Only thought I have is something that piques my memory about time stretching and similar - when I’ve asked in the past.

I was recently told that sometimes Cubase is not too good at determining what the tempo is , so things get messed up …AND that I should look in the pool to make sure the tempo is what cubase says it is .

martin.jirsak and raino are both really good at this stuff …hopefully they will see your post.

below may or may not apply - part of a conversation reply I had from user raino

"One thing to be aware of with Musical Mode is that Cubase does not always correctly identify the original Tempo of the Audio. So before making any adjustments it’s a good idea to look at the Audio File(s) in the pool and make sure the Tempos shown are correct.

Also you might want to take a look at the options for the Select (Arrow) Tool, specifically Sizing Applies Time Stretch. This will let you drag the end of the Audio Event and snap it to a Bar line to quickly adjust its Tempo. This works on both Audio Events and MIDI Parts in the Project Window."