tempo, media bay

I found a couple of loops i wanted to use in my media bay. I checked the box to align the beat to the project and everything locked in. But when i dragged the file in the the project window it reverted back to the original tempo.

Also when i am importing audio files recorded by someone else in to Nuendo I am not able to make the audio files conform to the tempo.

Are there some settings or preferences that I need to change?

Track needs to be in musical mode not linear time mode. Check the little clock in the inspector.

Find the files, the ones recorded by someone else, on your hard drive using media bay.
Check mark the folder to have it scanned by media bay. Enter the number of bars, (or tempo if known) info for each file. You can select multiple files and enter this info for all selected files if the tempo is the same.
Then when you import them using media bay they will behave as expected.