Tempo Rubato

The problem with the Groove Quantize method, in this instance, is that the source material does have to be rhythmic, and fairly stable tempo-wise.

Ahh… I’m hoping Ask video cubase 5 tutorial covers all of this in more than a generic way. Bundle 4 dvd’s. Beginner to advanced. “buy”.

hmm…I’ve tried it now… The tracks doesn’t respond to the tempo track.

I didn’t fully get:“Drag the events on all tracks, so as to make the first downbeat of the music correspond with a barline in the Cubase grid.”
I have to translate everything in my head to my language…I’m not english.Don’t know what events are.

The notes I tapped became different lengths…is there a way to make them all quarter notes?

It was difficult to make the tempo track musical when the song is playing mechanical and slower/faster.

Hi

Are you looking for something like this?

http://www.youtube.com/watch?v=-ySpfhRSsBM

http://www.youtube.com/watch?v=pltDy8hMcZg

Greetz Bassbase

Now it is I who doesn’t understand… you wanted the tempo track to correspond with your recorded music, yes? Do you mean that (after having completed all that) you then wish to change the tempo track, and have the music follow the new changes? Yes, that is possible (I’ll describe that at the end of my reply***).

I didn’t fully get:“Drag the events on all tracks, so as to make the first downbeat of the music correspond with a barline in the Cubase grid.”
I have to translate everything in my head to my language…I’m not english.Don’t know what events are.

Sorry, I didn’t detect any foreign accent in your post! :stuck_out_tongue:
O.K. your Project exists already… you have recorded some MIDI (and some audio?)… what you have recorded is placed on Tracks, and the things that exist on a track are called events (these could be MIDI Parts on MIDI tracks, or, for audio, they would probably be audio events placed directly on the audio track, or encased inside Audio Parts, if you had selected the audio events and gone into the audio menu>“Events to Part”.
So all I meant was, select everything you have already recorded, and slide it so that the first thing you hear lines up to a barline in the Project window’s grid.

The notes I tapped became different lengths…is there a way to make them all quarter notes?

So long as the MIDI track on which you record the tapping is set to Linear Timebase (and you should have already set all the other tracks to Linear Timebase also :wink: ), and the result of the tapping that you hear is correct with the recorded music, don’t worry about what it looks like… the tapping will indeed eventually look like quarter-notes once you have successfully completed the process.

It was difficult to make the tempo track musical when the song is playing mechanical and slower/faster.

By “musical”, I meant… “Imagine that your orchestra was forced to have a percussionist playing along, playing quarter-notes all the way through the music.”
This does in fact become easier with practice… when you are “tapping”, you are effectively being the orchestra’s conductor (except that you are following the orchestra, rather than the orchestra following you :wink: )… it is just the same mental process as the conductor waving his arms about :wink:

Maybe you should start by doing a small Test Project, where the source music is fairly regular and rhythmic… just to get into the method :wink:.

***If you then want to change the tempo track, and have the music follow the new tempo changes… easy for MIDI, a bit more complicated for audio (EDIT: damn! this is Cubase 5, right? this is more complicated than in Cubase 6, unfortunately)…

  1. Once you have obtained your correct tempo track, but before making any further changes to it, switch all tracks back from Linear to Musical Timebase.
  2. For audio (again, before making any further changes to the tempo track), for each audio track, select from the very beginning of the audio track to the end of the audio, using the Range Tool, then go to Audio menu>Bounce Selection (and answering “yes” when asked if you wish to Replace Events). For each audio track, go into the Audio Pool, and make sure that Musical Mode is activated.
  3. You can now modify your tempo track if you wish, and the music should now follow.

Btw, let me just remind you about this

:stuck_out_tongue:

Ahhh got you on the event thing:D It just sounded like a party(something big and complicated:P)

I only got MIDI tracks that I want to correspond to the tempo track.
I might want to change it further after making it first time.Don’t know yet…I’m thinking about doing it in pieces…Some bars first and then some more…as the song progress…So yes…

It’s a piano solo at the moment, with strings and flutes coming in later. A nice little piece to begin with. I started over and aligned everything snapped to a grid line. It looks organized. (still wondering how to record fixed lengths though) They all vary in relation to how long I held them down. they can be tiny bits to slightly bigger to very long. It’s impossible to manually make every notelenght a perfect 1/4. (‘mathematically’ the same lenght.)

Everything is timebased. The ruler is set on seconds (choices between:bars+beats,seconds,timecode,samples,60fps)
TT.png

The tempo track LOOKS good but the MIDI ain’t corresponding to it :stuck_out_tongue:
Screen.png

[Re-editing my reply… I thought it wasn’t working because you hadn’t set Left and Right Locators, but in fact it should still work anyways]…
Are you absolutely certain that all your MIDI tracks are set to the “clock” icon, in the Inspector (Linear Timebase), before doing “Merge Tempo from tapping”?

Other observations…
The Ruler Track that you created doesn’t matter.
The length of your tapping notes doesn’t matter either (Cubase is only interested in each tapping notes start) :wink:

From what I can see from your screen captures…
(looking at screen capture #2)…
It looks like your music starts somewhere between Cubase’s bar 4 and bar 5.
You should have dragged everything, so that the first note you hear corresponds with a Cubase barline… you merely dragged it so that the left boundary of the earliest MIDI part (the Violins track?) starts on a barline (but the Part starts with silence).
So you need to get rid of the empty space at the start of the MIDI Parts…

  1. Go into the MIDI Editor of the Part that starts the earliest
  2. Select the first note, then hit “L” on your computer keyboard. This will place Cubase’s Play Cursor on the start of that note.
  3. Back in the Project window, select everything, then go to the Edit menu>“Split at Cursor”.
    Now all tracks will have the “empty space” at the beginning separated from the remaining.
  4. Delete those empty Parts.
  5. Now, you can drag everything to line up with a Cubase Barline (from what I see there, that should be bar #4

Looking at screen capture #1,
You drew in some tapping beats for the count-in, right? You don’t need to do so (but, like I said above, correct the start position of the Music first, anyways.)

Now that you mention it…I do have every track on linear timebase(clock) BUT it doesn’t light up in yellow like the musical icon does. Why not? Every track is set to the clock icon,but it’s grey. If active it should’ve been yellow.

Everything aligned now.Thanks.

The tapping is recorded from keybaoard(“conducting”)

Yes that does look a little confusing, but it is in fact correct (the clock icon doesn’t line up).

Everything aligned now.Thanks.

Good! (got there eventually :wink: )

Still doesn’t work…Don’t know what else to do when everything is timebased.

Try to write down a detailed list of every step you are doing, and how you are doing it. (because, I promise you, if you do it correctly, it does work :wink: )

1.Open a fresh clean cubase to test this
2.Create a tempo track
3.Setting the tempo to 100 in the tempo track editor.
4.Switch in the transport bar to “tempo track” and not fixed.
5.Create midi track 1
6.Set musical to linear timebase
7.Record and play midi.
8.Quantize and snap it into place,first note starting at bar 3
9.Create a “conductor” midi track with a random click
10.Record the “conducting” on that track
11.Select and click “merge tempo from tapping”

The changes are made and I can see the tempo in the transport bar going up and down as I tapped…But the midi track doesn’t respond to anything.

Please upload a screenshot, showing this (i.e. with that MIDI track selected, and the Inspector visible)

7.Record and play midi.
8.> Quantize > and snap it into place,first note starting at bar 3

What are you quantizing? If you record/played with a “free” tempo, why would you want to quantize its notes to Cubase’s current 100 BPM?

Can you upload a small Project (which you have already “tapped”), so I can check if there is something else wrong somewhere?

9.Create a “conductor” midi track with a random click
10.Record the “conducting” on that track
11.Select and click “merge tempo from tapping”

The changes are made and I can see the tempo in the transport bar going up and down as I tapped…But the midi track doesn’t respond to anything.

If your MIDI tracks really are in Linear Timebase, then what you have written should work (i.e. the recorded music doesn’t change, but Cubase’s grid now aligns with it).

Can you upload a small Project (which you have already “tapped”), so I can check that something else isn’t wrong somewhere?

What are you quantizing? If you record/played with a “free” tempo, why would you want to quantize its notes to Cubase’s current 100 BPM?
The recorded data… I’m not the best player so I quantize it so everything is organized and played correctly(but to mechanical) Thus the need for tempo rubato so I can liven it up and still stick to the correct playing.It’s the same principle as written notes.It LOOKS tidy and mathematically correct.But with some life to it(humanization and tempo rubato “conducting”) It becomes what I want but at the same time keeping all midi data organized and snapped nicely. Does it make any sense?
proj.png
Midi inspector.png

Cubase file
Orkester template.cpr (747 KB)

(I shall reply later tonight… but I now see that I must have misunderstood your original post… “Merge Tempo from Tapping” is for a different purpose. … I’ll explain later)…
In the meantime… apologies :blush: :wink:

… later…
When you said you had played “rubato”, I had (mis)understood that you had played “freely” (i.e. ignoring Cubase’s metronome completely), whereas in fact (from what I see in your .cpr, but please correct me if I’ve gotten it wrong again :stuck_out_tongue: ) ), you seem to have recorded at a steady 110 BPM (not 100 BPM as you wrote earlier), or at least, after quantizing, the recorded MIDI does line up perfectly with Cubase’s grid, when Cubase’s tempo is set to a fixed 110 BPM (well, at least, after having dragged the events, so that the Piano starts on the first beat of bar #2 here).

Am I now right in thinking that, after quantizing, and before doing any tapping at all, the music was already in perfect sync with Cubase’s grid/metronome? If so, then no tapping is necessary. But as you said, after quantizing, the result is very mechanical. (and in this case, the most direct approach is to set everything to Musical Timebase, then edit the tempo track… or use the Tempo Track Editor’s Tempo Recording slider… although it is a little difficult to control the results).

Or… different approach :wink:
Were you happy with the (rubato) tempo of your recording, before quantizing (but you wanted to get Cubase’s grid to line up with it, so that the other tracks could be in sync/edited)?
If so, the method I had described was in fact correct, but you shouldn’t have quantized your playing…
The whole purpose of “Merge Tempo from Tapping” is to allow to get Cubase’s grid (and therefore, metronome) to line up with already-recorded music, without changing the way the music sounds at all (in other words the notes stay, physically, in exactly the same place in time, while the grid is adjusted to fit it, rather than the other way round)
Also, I had meant that your tapping should match the music that you were actually hearing (i.e. it should have been like any other overdub)… looking at your new tempo track here (btw, the MIDI events on your tapping track are missing, except for the first three bars), I can only guess that what you were tapping never matched the music at all… were you, instead, tapping out what you wanted the tempo to eventually be? (I’m afraid Cubase isn’t capable of that function, it would require to slave to MIDI Clock, and Cubase doesn’t have that).
(I also observe, from your tempo track, that there are tempo events only every half-note, not quarter note, which would partly explain why the end result was incorrect).

So, have I managed to confuse you still further? :open_mouth: :slight_smile: (if so, just erase your memory of the last few days completely from your brain! :stuck_out_tongue: )

To recap… apart from getting the music and the tempo track to match, was the (rubato) tempo of your original playing o.k. for you (i.e. before quantizing)?

Let me clarify…people that don’t know what the *ell they’re doing are very vague :smiley:

I start off by recording without caring about the set tempo or metronome.I don’t use the click,I only play freely. What I really want I think is the orchestra to follow the piano solo.(my freely played solo) BUT I don’t play that perfectly and need to do some editing aswell. And as I’m playing this solo I’m uncounsciously playing rubato and in an unkown tempo. I’m playing by ear. It sounds good but it doesn’t snap to the grid,and it doesn’t follow cubase in any way.It’s just a live played track sitting in cubase. So it SOUNDS good but doesn’t look ORGANIZED.

I’m still undesisive wether I want to “conduct” quantized tracks or have the orchestra follow a live performance.


“Am I now right in thinking that, after quantizing, and before doing any tapping at all, the music was already in perfect sync with Cubase’s grid/metronome?”
Yes.

" If so, then no tapping is necessary. But as you said, after quantizing, the result is very mechanical. (and in this case, the most direct approach is to set everything to Musical Timebase, then edit the tempo track… or use the Tempo Track Editor’s Tempo Recording slider… although it is a little difficult to control the results)."
Tried it…it’s VERY difficult… :confused: If only the ramp function would make smoother curves with closer points it would work easier.

“Were you happy with the (rubato) tempo of your recording, before quantizing (but you wanted to get Cubase’s grid to line up with it, so that the other tracks could be in sync/edited)?”
Yes. I wan’t the other tracks to follow the freely played track. You could say the track played by ear is the conductor in a way. But the thing I was also thinking about was…if I recorded it,quantized it…I could conduct that mechanical track into a rubato performance.

"If so, the method I had described was in fact correct, but you shouldn’t have quantized your playing…
The whole purpose of “Merge Tempo from Tapping” is to allow to get Cubase’s grid (and therefore, metronome) to line up with already-recorded music, without changing the way the music sounds at all (in other words the notes stay, physically, in exactly the same place in time, while the grid is adjusted to fit it, rather than the other way round)
Also, I had meant that your tapping should match the music that you were actually hearing (i.e. it should have been like any other overdub)… "

Ok Then I misunderstood…I was trying to conduct a quantized track to play rubato…I didn’t follow it. No the tapping didn’t match my music at all.

“To recap… apart from getting the music and the tempo track to match, was the (rubato) tempo of your original playing o.k. for you (i.e. before quantizing)?”
Yes.Yes it was :sunglasses:

Good… so we’re back on track then :slight_smile:

  1. Do as you were doing… record your freely-played piano part, but don’t bother to quantize it (you’ll see, that once you have completed “Merge Tempo from Tapping”, it will be much easier to edit the bits you aren’t happy with…, and also, much easier to overdub the other instruments :wink: )
  2. Record your “tapping” track… as you now know, you should play it in time with the already-recorded music (that’s what I meant, earlier, about making the tapping track sound “musical”, it should eventually sound like the click was intended to be part of the music).
    As I mentioned in my previous post, it looks (from your uploaded cpr), that there was some confusion as to whether what you were tapping was supposed to be quarter-notes, or half-notes… when you do the “Merge Tempo from Tapping” operation, the tempo events on the tempo track should take up the same length as your tapping track… if it is about half the length, or double the length, you will know that you made the wrong choice, either when tapping, or when making the setting in the Tapping dialog. No problem, just “Undo” :wink:.

Once you get used to doing it, you’l find it gets much easier :wink:.