Tempo Track causing dropouts

My project is a MIDI only project, using about 50% of cpu.

If I try to put a tempo change on the tempo track Cubase drops out badly when trying to play through the tempo change.

Cubase 10.5.20 on Windows 10.

It’s a wonder that anyone can get anything done with this damn Cubase.


Where are the MIDI Tracks routed to, please? To hardware synth or VSTi?

All VSTi.


Could you try to increase your Audio Device Buffer Size, please?

I thought the buffer was at max, but it wasn’t for this project. I will try that later.

Still why would something as simple as tempo change for MIDI cause an issue when the cpu is only at about 50%?



The heavy part is not the MIDI, but the virtual instruments here. The Buffer is not about the CPU only, it’s about the whole communication among hard disk, RAM and CPU.

That doesn’t make sense to me. It seems all it has to do is to send the MIDI info to the VSTi’s at a different rate.

However, I suppose if there are any instruments or effect that might be set to the tempo for timing that might have an impact. That would be a very badly behaving plugin.

Anyway, originally my buffer was at 192. I put it to the max of 2048 and Cubase still choked on an automated tempo change (tempo track) in exactly the same way.


Could you test your system by using LatencyMon utility, please?

To what end? I turned off the latency compensation in Cubase, which disabled many plugins. It made zero difference?