Terrible volume of DoricoBeep on first Dorico playback


When I first started Dorico and played a sample project, not having installed Halion Sonic SE yet, the DoricoBeep went at me at full volume coming from my Mac’s speakers and almost blew my ears off. Making things worse, since my system audio output was configured to my Scarlett2, my initial instinct of muting the audio through the keyboard didn’t work, and it took me an extra couple of seconds to stop the playback.

(At least, that’s my recollection of the exact steps and setup and what occurred - it was a week ago already so I might have one of the details wrong. Not the audible experience, though :slight_smile: )

I suggest either/both lowering the default volume of the DoricoBeep instrument, or taking the system-set audio output as the initial one for Dorico, not the Built-in output. I hope this makes sense.


That is a driver setting. Choose Edit > Device Setup, click the ‘Device Control Panel’ button, and switch off ‘Set device attenuation to 0dB’, and that should disable this behaviour for future starts of Dorico.

I no longer have this issue since I’ve already configured my Scarlett as the Output Audio device (and also installed Halion Sonic SE so it plays rather than the beeps)

My point is this is a potential bad first experience for many people with a similar setup who run Dorico for the first time and attempt playback before setting up their audio device. In my particular case described above, the result was very, very loud beeping. So I suggest mitigating this problematic first-time behavior in some manner.

This has been discussed here many times. The CoreAudio2ASIO component that is used for playback through the Mac’s default audio output is a component that is shared with Cubase. The Cubase team have explained to us that they consider it essential that this option is set this way. We have certainly considered whether we can make some kind of configuration change in order to override this default, or ask them to create a fork of this component with a different default value, but none of these things are trivial to do. That does not preclude is making changes in the future, however.

How about automatically opening up the audio output configuration dialog on first-time startup?

Unfortunately I don’t think it would necessarily help, as (without making any judgement) many users wouldn’t know what to do with an option that is couched in terms of attenuating the output to 0dB!

All the more reason to turn disable it as the default. Why is it not possible to check if the preferences file exists and if not, then disable that preference?

I’m not sure anybody has said that isn’t possible, Dave. But it’s not only a matter of something being possible, as surely you understand without me pointing it out…

I’ve heard the arguments on this issue. They were based on this being a pro app like Cubase and Pro users know to include attenuation in their audio chain.

Well it’s not a pro app anymore and there have always been non-pro users that by your own admission don’t really understand these things.

I don’t understand why this isn’t the single most important thing to fix of all this things you are doing. It would seem to be in Steinberg’s best interest to disable this preference on default so that non-pro users (of which there are many) do not damage their equipment or their hearing.

Any solutions for this issue on Windows? I just got Dorico and it’s essentially unusable with headphones for me without injuring my ears…

Hi all,

Does anyone know of any solutions to this in Windows? I have an ASIO RealTek driver and the attenuation option doesn’t even show. The volume on Dorico playback is binary: off or on ridiculously loud. Any suggestions for fixing this so I don’t blow my eardrums out? Thanks!

Thanks very much, ULF. Switching off ‘Set device attenuation to 0dB’ seemed to work. This just started happening the past week and I have been using Dorico Pro for about a year, I believe. What could have caused this? There has never been system volume change when starting Dorico or opening a score until this past week. Thanks again.

To be honest, I have no idea what might have changed the setting, if not you yourself did it accidentally.

Sorry for bumping up this old thread. Could you please tell me which file on macOS is the one that saves the state of “Set device attenuation to 0dB”?

I am thinking of writing a bash script to automatically override it (to turn it off) and use cron (a terminal tool available in macOS) to let this operation gets performed every minute. We Dorico users don’t want this enabled by all means necessary.

The file is ˜/Library/Preferences/com.steinberg.component.coreaudio2asio.plist
But do at your own risk. Also note, it is a setting per each device, not a global switch.
And furthermore, once it is switched off, you should not be bothered anymore, because a program will never change the value, it’s always an active user decision.
The only automatism is when you add a new device, then that option defaults to ‘On’.
But with the next Dorico 4 release it also won’t happen anymore, because we changed the default now to ‘Off’.
Having said all that, I really don’t see a need for writing such script.

1 Like