Text Dragging Behaviour

I love how text automatically avoids colliding with other elements, but when a large number of text elements are involved the auto-placement becomes less than ideal:
Screen Shot 2017-03-01 at 12.53.51 PM.png
These situations are in the minority, so I’m fine with manually dragging the text in Engrave Mode in these cases, but that’s where I’m encountering a problem. I’ve made a short screen recording to show the behaviour; I think it’s pretty self-explanatory. https://youtu.be/Rb7gcdmXPvg

Is there a setting I can change to stop Dorico constantly moving other text elements in response to me moving one manually?

You could try creating a Note Spacing Change to space the notes wider, and make room for the text items to fit on a horizontal line.

Go to Engrave mode, select the first note, and look in the Engrave menu.

Or, looking at the video, move the system break so you have fewer notes in the first system.

Or if all else fails, make the staff size smaller (Setup menu, Layout options / Page setup).

Very interesting! After changing the quarter note spacing to 5 instead of 4, the text elements don’t react to the movement of other text elements at all, even when placed on top of each other.

Or make the text font smaller :wink:

It already is at 8pt, which is (I find) around the limit for reading at a normal music stand distance.