Text editor window

Hi dear Doricians !

Not sure this topic has not been already talked about, but anyway…
While doing my vocal score of Carmen, I had numerous pages of dialogs to input, and of course I wanted to make it all in Dorico.

Here are some improvement ideas (and maybe lacks due to a bad workflow) :

  1. The text editor is stuck, I cannot move it, and when working with a zoom level high, I always have to navigate (which is not easy when you input text, the mouse has to be on the blue part of the screen…). I suggest a good thing would be to make that window moveable (or if it is, just tell me how)

  2. It is impossible to input some things used in french typography, like short hard spaces (before every two vertical signs, like ; : ! ?)

  3. When resizing a whole text (by default 12pts) to 8pts to make it fit the page, the empty lines between the dialogs would remain 12pts, no matter how hard I delete them and redo them at 8…

Thank you !

Marc, short hard spaces you can input with (I think it is) Shift-Alt-Spacebar. Can’t check, as I am on the road with Laptop only and no second Dorico license…
But it is definitely there, I have used it.

Shift + Alt/Option +Spacebar it is.

Dear k_b and Mark,
I’m sorry, but I use this shift+alt+space as an unbreakable space for a very long time in Dorico. I even gave the same advice you give me, over than a year ago… But it not short at all! Same problem that I had previously with short dashes (that I have to write in an external editor, copy-paste into Dorico… Maybe the same workaround works with spaces, but then my request abiut it would just cover spaces AND dashes)
Is this problem limited to french language? I’m talking here about very specific typography details — which are obviously ignored by most in the engraved literature — I often see those!,?,:,; without that short unbreakable space in french operas. The rules of french typography should apply to french lyrics, shouldn’t they?

Is the idea to have slightly more space between a word and following punctuation mark?

Marc, you did! Thanks :slight_smile:

Have you tried somehow entering the actual ASCII or Unicode values for the exact punctuation you need - maybe with Alt/Option?

Dear Marc,
thank you for your reply. This is something I didn’t know so far. I was sometimes wondering about that extra space before the ! and wondered, wether it was a habit from the typewriter area…
But there seems to be more to it :wink:
I know about some french/swiss typography differences like the « » and » «

Is the idea to have slightly more space between a word and following punctuation mark?

Than no space, yes, Derrek.
Actually, we have a small non-breakable space which is perfect before the : ; ? ! signs (see https://fr.wikipedia.org/wiki/Ponctuation#Drillon) and I find Antidote can input those (when it corrects my mail, for instance) and of course XeLaTeX inputs it right. The other Wysiwyg applications do what they can, and I cannot tell more since I do not use them for some years (since I discovered XeLaTeX, actually).
I would love that Dorico could allow me to input those spaces, “tirets” (or better, do the same job LaTeX does when I tell him I’m writing french…) without having to catch some workaround outside the application.

Have you tried somehow entering the actual ASCII or Unicode values for the exact punctuation you need - maybe with Alt/Option?

Yes, I tried that, and like the problem I had with the “tiret”, it could not work inside Dorico.
Anyway, this is just problem 2)
Am I the only one here with problems 1) and 3) (not french-related) ?

For those who could be interested in that thread :
I found the way to solve 3), i.e. make the empty lines follow the size of the text. I had to create a new paragraph style (which I called dialogs) and with a size of 10pts and noticed the empty lines would follow that.
Another nice improvement would be to be able to have a different spacing when starting a new paragraph (similar to what happens in a wysiwyg app when pressing enter instead of new line with shift enter or alt enter, or when passing two lines in LaTeX to create a new paragraph). But I understand that this is not a priority, since those things can be done in another program and the page added after in PDF. [Edit] Found in Paragraph styles : gap after paragraph. You really have thought this nicely !

Here is an example of a dialog page edited in Dorico. I think it is almost perfect, the only things I could not do are
• small capitals for the names of the characters
• short unbreakable spaces
• automatic hyphenation
but I have to admit that, for a music editor, the result is very nice.
Thanks for your constructive comments, if there are some !

Marc,

Given that Dorico is not a DTP application, I’d say your results are extremely good.

Marc - this is beautifully done! Bravo!

Marc,

This is very nice work, but did you try the espace fine insécable (étroite)? The code is U+202F.

Thanks, Marc-André. I will try that!
[Edit] I just tried and it did not work : when entering text, I see the short space appear (exactly the one I want) but once I leave the popover, no space is drawn. And when I try to use Unicode in a text frame, it just does not work at all, all I get is beep beep when entering the code…
I’m quite disappointed but I understand it cannot be a priority. Yet I have the feeling that most of the music literature is badly rendered, when dealing with french texts, and especially that part of typographic details. I wish I can do better than that — unless someone explains me that those rules do not apply in music.

Hello Marc,
I don’t speak french. Still I am copying a manuscript of a french opera from the late 18th century (1779)… It turns out, already the title is written in different ways. Is it « L’Isle Déserte » or is it «L’Île déserté» ?
When copying the text lines I feel, some spelling unusual, some things strange. Is it on purpose, is it subtle play with words of different meaning etc…? Some things look like a misspelling to me, or may be, the way things were spelled was not that much standardised? As it turns out, the ms I am copying from is already a copy from someone else at that time. Also the composer being german, gave himself a french name. Either because it was en vogue at his time, or because he had other reasons. I will have to check the biography…
[Edit] ok… he lived in Bordeaux for over 30 years :wink:

Marc,

Small caps may well be font-dependent…

could well be that this is just not (yet) implemented… requires an algorithm that has not yet been written, or a code library that is not accessed

• automatic hyphenation

Yes, Mark, I know all fonts cannot display small caps… But, for those fonts that can be in small caps, there isn’t any feature in Dorico to choose it, is it?

Marc,

It seems as though small caps is applications-specific. If so, it also seems that Dorico hasn’t yet implemented it.

I know this sound silly, but have you tried entering the text which you want to be ‘SMALL CAPS’ as such in capitals, then reducing its font size?!

Thanks Mark,

I did not think about it. Well, it seems really too long to do that (it’s so easy to do in XeLaTeX…), so either I’m fine without it — and I wait for some implementation, or I’ll spend some hours to modify that. Or I use XeLaTeX and mix PDFs from different apps :wink: