Text over tempo mark

Hi,

I’m trying to put the text (Air - John Blow) over the tempo mark, but I can’t find a way to do it.
image
Is it just me or there isn’t a way to do it? (besides moving it manually, of course)

Thanks in advance

Manual change is the way :wink:
If this is system text (it shoul be) and you want this to appear in parts as well (I suppose you do), make sure you turn the properties setting to global. Then offset the y value by 6 or 7. It should offset that text for all layouts.
[Edit]: of course, Lillie (right below) is right, so make sure you follow her advice too !

1 Like

If you want to swap the 2 (and have the tempo mark ending up closer to the staff than it is currently), deactivate collision avoidance for the text first before moving it; that way Dorico won’t continue to calculate the tempo’s position as if the text were below it.

2 Likes

Thanks for the solution; I did try moving the system text manually, but tempo mark wasn’t moving; thought that I would have to move both. Now I understand what the collision avoidance is for.

Wouldn’t it be easier to use a flow heading for the title?

1 Like

Hi @b_e_n,

Normally, that would be the case, but I’m working on a project that has many flows in the same page, some of which don’t need a title. Given that Dorico doesn’t let you have flow with and without title in the same page, I opted for not having a flow title in any of them.


This is an example of the project.

Aha, I see. In this case your solution seems to be the easiest. Easier at least than fiddling around with frames.

1 Like

Hello, I’m coming back to this old thread with a similar question.
I insert boxed text (“VERSE”) at the metronome mark. The metronome mark, of course, goes up above it. I check “Avoid collisions”. I thought the metronome mark would return to its default position, but it remains up in the air. It remains there even if I manually move the boxed text.
How can I get the metronome mark to naturally return to its position?
Thanks

You need to activate “Avoid collisions” and then make sure the checkbox is deactivated (unchecked).

You might also want to double-check the metronome mark didn’t already have a graphical offset set by selecting it, and checking the Properties panel.

Dear Lillie, Many thanks for the lightning-fast reply.
You’re right. I activated and checked the box. Now I’ve unchecked it and everything is perfect.
Wishing you a happy new year.

1 Like

You’re welcome! The reason it works like this is that there’s a default setting in Engraving Options for whether all text items across the entire project avoid collisions or not as their standard behaviour.

Therefore, in order to control individual text items independently of that default setting, you need to be able to tell Dorico “override the default”, and then whether that override is to enable or disable collision avoidance (as you might want the reverse: ie to have the default behaviour be text items don’t avoid collisions, but one or two should)

1 Like

Thank you. That’s very good to know.

Could you maybe consider creating an option to switch the text’s position when appearing at the same bar as a metronome mark?
“Switch default text to above metronome mark”.
It’s just that in all the scores I’ve seen from various publishers, they always put the text above the metronome mark. Why have you gone the other way?