The age old soft elicense issue. So frustrated.... Please help!

This is my first post on here.

I have just bought Cubase Elements 10.5. Unfortunately all the potential joy of the purchase has been thrown back in my face by this frustrating registration process. I don’t consider myself stupid or techno phobic, but this is possibly the worst registration process I have ever encountered in my life.

I have tried every possible fix available on the internet, as far as I can see.

On installation the soft elicense isn’t created ( I know you have read this many times).

I have tried the Installation Helper, the installation fails every time. I open all the programs as admin.

I have tried the cmd prompt fix: “C:\Program Files (x86)\eLicenser\POS\SYNSOPOS.exe” /regsel

All software and Windows 10 are up to date.

I have been struggling with this for a day now, and seem to be getting nowhere, to add to the confusion earlier my 6 year old daughter somehow managed to delete my Steinberg ID. I presume not to much of a problem so far, as I have not yet been able to register a product online!

Is it possible to create a soft elicense a different way than I have mentioned already?

Please, if anyone out there has a solution, it would be very much appreciated.



Yes. Yes, the actual process, as experienced by actual customers, is terrible.
It’s a series of small, seemingly not so bad, problems, each step of the way.
If they could put a competent developer on each of those steps, it wouldn’t take much to make it much better, but my guess is that each of the steps is owned by a separate organization or product owner, who each have a higher priority of their own, and thus fixing the overall experience just doesn’t get attention.