The curse of "US Letter" paper in the USA, and Dorico

I want to be able to have everything set to “concert size” 9x12. My printer handles that. Mostly, I can save things as pdfs and sent them out for printing elsewhere.

So, in initial layout, I set it to 9x12. In engraving mode it looks good. But when I go to print mode, 9x12 is not an option. I see the Mac Dialogs on the left, and set that to 9x12 paper (and I have to redo this evert time). But in the left panel, 9x12 is nowhere to be found, and the way the music looks there messes up the margins depending on what paper size I choose there. And this stays messed up when I save as pdf.

Am I missing something?

David Froom

Unfortunately if Dorico doesn’t know that your printer supports 9" x 12" paper, then it won’t appear in the list of paper sizes on the right-hand side in Print mode. The custom paper sizes you can define in the OS Print/Page Setup dialogs are not accessible to applications that use their own printing subsystem (as Dorico does, because it uses the Qt application framework). You should find that when you export a PDF using the Graphics options on the right-hand side in Print mode, the graphic is exported to the page size specified in Layout Options rather than the page size chosen on the right-hand side in Print mode, but when you print it will use the page size specified there.

That solves it. Thanks.

All my family genealogist was able to document is that I have a direct ancestor named “John Williams” who arrived at a certain county in the British colony of Maryland, America in 1724, presumably from somewhere in the British Isles. I have thought about appearing at random locations in the British Isles and shouting “Hey, does anybody here have an ancestor named ‘John Williams’? We must be related! Take me in and help me get citizenship.” But I don’t think that would be efficacious.

No, this doesn’t quite work! I set up “US Letter” as a default according to your instructions.
But when I create a new score with multiple players, Dorico duly formats the Full Score in US Letter, but each of the Player individual parts are automatically formatted by Dorico for A4!

Sibelius has always done exactly the same thing. Create a new score, set the Layout to US Letter, yet the individual parts get automatically formatted to A4.

The only thing that a Dorico user could do at this point is for the user to go to the Setup mode, choose the Layout settings for each individual Player in turn, and manually change each to US Letter, and then go and check to see how things have been shuffled around on the pages as a result of the reformatting.

This is a real problem for a composer or copyist. A person could carefully create a full score in US Letter and easily overlook that Dorico has formatted pages for individual parts for the wrong paper size, A4. Then those parts get sent off to the USA musicians as PDF files. Everybody prints out their parts on their local USA printers and wonders why their parts all print out smaller than they are supposed to (making them harder to read on the music stand), formatted too tall and too narrow on the pages of paper. I have seen this happen with Sibelius scores time and time again – the full score is formatted to the correct dimensions but the individual parts are formatted wrong because what Sibelius did with A4 was not at all obvious to the composer.

I would have hoped that after all these years I wouldn’t have to deal with this anymore, because Dorico is designed not to be burdened with legacy problems.

If you select a part in the list of layouts in Layout Options, then set the page size to ‘Letter’, then from the ‘Layout type’ menu in the bottom left corner of the dialog choose ‘Part’, then click Save as Default, that will take care of it.

For me, both score and parts of a new document come up formatted for US Letter.

Are you sure you “saved as Default” BOTH Score and Parts as “Letter”? You may have to do this as separate Apply, Then Save operations.

Edited to add: Daniel took care of it while I was posting…

But in Print mode, everything is still A4. I can find no way to set the default to Letter.

Huh. I thought I had it solved because when I clicked the “OS X Dialogs” button to see the system printing window, it shows “Letter,” which is what I want (and what my printer is prepared to do).

But looking at Dorico’s Print options on the right, I see that the printing default for score and parts is something called “Statement,” which I never asked for and had never heard of. (It turns out to be half a US Letter sheet. My Layout Options continue to remember that I want Letter.)

In Print mode, you get whatever Dorico thinks is the default paper size used by your printer. Unfortunately this isn’t necessarily what you’d choose in the macOS Print dialog: applications that use their own printing subsystem, as Dorico does, unfortunately can’t “see” inside the OS Print dialog or its data, as that data is opaque by design and cannot be introspected by applications.

Okay, I understand that, I think. Thank you for responding. So my questions are (1) Why does Dorico think my ordinary US inkjet printer uses 8.5" X 5.5" paper as a default? and (2) how can I convince it that I want US Letter?

I don’t know the answer to the first question, and at the moment I don’t think there’s anything you can do to affect the default choice in Dorico, so you’ll need to remember to do this before you print, at least for now.

This is all very interesting (I live in an A4 world but have had to get paper specifically cut in different sizes for printing, or checking). Just to complicate this, I have needed to be aware of tablet size and proportions also.
If I know it is destined for iPad (4:3 proportion) I use Concert (9 x 12) layout and set a minimal margin, but there are so many other tablet proportions and sizes also—which produces a similar problem (or worse because you cannot know what it will be viewed on).
Any improvements in this whole print area would be appreciated.

Minor detail: I saw this too, and think it strange. I’ve been printing stuff in the USA all my life and I’ve never heard of or seen “Statement” sized paper in real life or in a configuration dialog for a printer. Perhaps this is an archaic type of paper that the Dorico team found listed in some reference source?

If I am not mistaken, this sequence of steps doesn’t work because you left one step out.
Here is what I have had to do, in this exact order:

  1. Select one Player in the list of Layout Options.
  2. In Layout Options, in the left pane, select ALL Players.
  3. Under “Page Size” choose “Letter”.
  4. At the bottom, pull down the Layout Type: menu and choose “Part”.
    5) Click the Apply button in the lower right.
  5. THEN click the “Save as Default” button in the lower left.
  6. Close the dialog.

In my tests, if I failed to click the “Apply” and “Save as Default” buttons in the correct order, then the change I made failed to take effect the next time I opened a new blank template. All Player parts were back to A4 again.

Still, in this whole scenario, Dorico comes out-of-the-box with all the templates set up to print individual parts on A4 paper. It is up to the user to follow these tricky steps to alter all of Dorico’s templates permanently to be set up for USA-style imperial inch paper sizes. I still think this is too confusing for the average musician in the USA. I would like to reiterate my earlier suggestion that Dorico, upon installation, have a “Worldwide Paper Mode” and a “USA Paper Mode”. In the latter, all the Dorico templates would already be set up for the USA-imperial-inch family of paper sizes, and A4 and its family would be banished and never appear anywhere by default.

Please refrain from speaking for people you do not know.

I just started a new project in 1.2, and I see that it still thinks that “Statement” is the size of paper my OfficeJetPro 8100 wants to use. Even after I correct it to “US Letter,” there follows a pair of lines saying “Print odd final page on / Statement”, which cannot be edited or changed. I guess I need to make sure never to have an odd final page!

I think I have this figured out, at least for me, a US Mac user. I set my paper sizes in setup mode (my current project has 11x15 score and 9x12 parts). When in print mode, I go to the lower left of the screen and choose the page setup to choose whatever size I want (eg, 11x15 for the score) Then on the upper right of the screen I choose graphic, PDF. Then click export.

The music looks wrong in print, but the PDF export is perfect and fast.

I dont understand why life is so difficult for some people. I moved USA–>EU–>USA–>EU, changed the paper size in my printer each time and once I had told Sibelius what to do, had no problems. M$ Word, on the other hand, took much longer to learn; but did so in the end. The features encountered above are not inherent to Dorico or Sibelius: they are part of what is called “computer literacy”. :slight_smile:

Actually, much as I prefer A4 for written documents and for its superior elegance, I find that Letter size is just that little bit wider and allows more measures per system, and the extra height of A4 is no advantage for music.

I cant remember when the A sizes were first adopted in the UK. But before that we had 10x8 and a multitude of other sizes (see, also different from the USA sizes, which I suspect go back to Benjamin Franklin!