The cursor in 7.5 is fine

All this time i have been getting really frustrated with the flickering cursor when zooming in but today flicking through my Bios settings i noticed that my hyper threading was enabled on the motherboard sooooo i disabled it and fired up Cubase and guess what ??? No more flickering cursor , absolutely solid and as stable as hell ,so ok i admit it I’m an idiot for not noticing this earlier :wink:
So if anyone else has this issue then check your hyper thread settings in your Bios to stop yourself from falling into the idiot trap . :wink:

Good luck and peace :wink:

Not clear what you mean. Please explain precisely which setting you changed.


It’s a standard setting in the computers BIOS (as he states).
If this isn’t clear, or you’re unsure about this, it may be best to leave BIOS settings alone, or let a qualified person do this for you.

Yes I am aware of the BIOS settings, but of course each motherboard’s BIOS settings are different and it may have been helpful to know the precise parameter for the motherboard concerned. It seems a radical move to have to adjust the BIOS settings of the computer in order to stop the flickering cursor, but if it worked then why not. However, this may be adversely affecting the performance of the computer for everything else.

It is recommended that Hyperthreading be deactivated.
See the KB Article[o_system]=2&tx_p77sbknowledgebase_pi1[productfamily]=2&tx_p77sbknowledgebase_pi1[product]=337
You edited your post which initially asked if this was a windows setting. I assumed you were unfamiliar with BIOS settings.

Hi BriHar,
Thanks for the info! Just tried de-activating hyperthreading on my system’s BIOS to see what happens to the flickering cursor. Unfortunately, on my system I see no improvement. The flickering is unchanged.

I did read elsewhere that switching off the hyperthreading is no longer necessary for cubase as a general measure. Some experts have suggested that the KB is out of date in this regard.

I think the story with multiple cores, asio guard and cubase still has not seen a definitive endpoint in it’s development.

For more info on the subject:

There are a lot of people who experience trouble with modern systems when trying to use the full core power of a system. Using hyperthreading can be an advantage in modern systems, but it can decrease performance too in some conditions. It depends on the way the system is build and the way the system uses cubase and what version of cubase you are using.

To kill at least one faulty idea. HT gives you a double amount of “virtual” cores, but using HT does not at all mean you “double” the resources for your system. HT is a method to try to process things more smoothly. In most cases the differences are expressed in percentages. Read the article and the references in it, and you will be probably a lot wiser. So in some cases your performance can indeed be better with HT off. (only using “real” cores)

Enabling Hyper-Threading while ASIO Guard is active usually has a positive effect on the overall system performance and is the recommended combination for cubase 7. Only in rare cases - e.g. with projects using many “live” tracks - Hyper-Threading can still lead to performance issues. Again, please refer to the dedicated ASIO Guard article for details.

To those rare cases we at the forum might add also specific GUI related issues and the fact that some people still have spikes on the asio meter even with the lates asio guard implementation. Other weirdness includes flickering cursors and so on…

It looks like the graphics handling and the asio handling is done by the same “real core” in the OP’s computer which creates some sort of traffic-jam on that core. DIsabling HT gives better performance for him.

But again: it is just my opinion on this, and i certainly would like to be given further insight by someone else with more knowledge on the subject regarding this issue on how modern systems with multiple cores should ideally be tweaked to run the DAW’s in an optimized way.

kind regards,


I did not change the hyper threading threading setting for the cursor , i was just optimising my Daw and just by share luck this rectified my flickering cursor .
As you say every motherboard is different ,it could of been a graphics related issue ,all i know is it’s now as it was in C5 but still with the white masking .
You haven’t supplied any system spec so it might not be relevant to your setup .

The board im using is the P8z77v pro thundredbolt .

That may be true, the info is indeed more pertinent to XP.

You are not an idiot, you are a genius.

I wouldn’t go quite that far Hyper lol but thanks .

Right ,now ive just opened up Halion 5 since disabling the Hyper threading and it loads up so much faster , with 3 monitors in stand alone mode i used to get major lag but not any more it opens and loads super duper fast now , very impressed sooo again if anyone is having lag problems Disable you Hyper threading in the bios and there is a good chance this will be resolved .

Im a happy bunny :wink: