The good old midi sync issue (notes recorded earlier)is back

Hello there, i have just upgraded to Cubase 8 Pro a few weeks ago, with the hope that the midi sync issues that have been around cubase for (at least) the past 4 major versions were fixed, however, i was wrong.

MIDI notes are recorded TOO EARLY, and this is BUG that is not present in any other DAW (i have tried to reproduce this issue in PT, Logic and Reason and none of them show this incredible bug).

This forum is FULL of users complaining about this and yet Steinberg seems to completely ignore this problem.

As they say, an image is worth a thousand words:

https://youtu.be/O2HXNQP2iwE

I decided to post a video to avoid the kind of “your playing abilities might be bad” response.

The video clearly shows what is happening to a LOT of users, and again, rewriting the song in any other daw won’t show this horrible drift.
Notes are recorded at least 1/32th earlier than they should, and while this could be fixed with quantization, or just by applying some delay to the track, working like this is absolutely unacceptable.

Enabling “Constrain Delay Compensation” improves the issue by a few milliseconds, but clearly does NOT fix it.

My hardware:

Mac Pro running 10.10.3 with 32GB of ram.
Focusrite Saffire Pro 40 with latest drivers.
Novation 61SL MKII connected via USB and Roland Fantom X8 connected via MIDI to an emagic AMT8 interface.

Same problem here. I record the same part at the same time, one MIDI track with a VSTi (EZkeys) using Roland XP-10 as a control keyboard and one audio track with Roland XP-10’s audio outs. So the MIDI and the audio tracks should record exactly the same playing. But they do not. MIDI record is very very harsh, annoying…

Is midi timestamp enabled?

Remove “ignore port filter.?”

http://www.steinberg.net/forums/viewtopic.php?f=226&t=72585