the stem directions of the tied note in ossia bar when cue notes are assigned

The stem directions in ossia bar are not correct when cue notes are assigned. Please see the following example:

I’d need to see the project itself, not just a picture of it, to provide any further insight on this.

Stem and tie directions generally will go wrong when inserting cue notes. (Remove the cues from the example and everything is fine.) Furthermore, adjusting the tie direction will affect only the first tie, see example. (409 KB)

BassoContinuo, though I’m not looking at your specific project right this second, I believe the solution is (extremely) simple:

Where there are two voices on a stave, Dorico respects the voice direction. If you’re using an Upstem voice, the stems point up. If you’re using a Downstem voice, the stems point down. This is expected behaviour, even when one of the voices is a cue that appears above the stave.

Remove the forced stem directions and the tie directions, then select your main voice and Change Voice to Downstem Voice 1.

pianoleo, thank you for your advice. It solves the situation above. But I have to adjust the main voice depending on whether the cue notes are above or below. Wish that Dorico could get this right automatically.

I could resolve the problem by executing “Force stem down”, but I also think that it would be better if Dorico could automatically do it.

prko, unless I’m very much mistaken, the voice in question is an upstem voice. Rather than forcing stem directions, just set it to be a downstem voice. Assuming there’s only one voice on the original stave (the one you’re cueing from) this won’t make any visible difference there, at all.

Oh, sorry! It is my misunderstanding.
Yes, setting the voice to a down stem voice resolves the problem as well.
It is a better resolution!