Third-party plugins crashes Cubase after Windows Update

After I got the latest Windows update (Windows 10 Pro v.1703 64-bit OS build 15063.413), most (all?) of my 3rd party plugins immediately closes Cubase when I try to open their VST editor (click on the small “e”). The Cubase stock plugins seem to work, at least all I have tried.

I have tried to remove all 3rd party plugins from the VST folders to see if any rotten eggs are in the basket, but the Waves plugins and DRMeter (from MAAT) still crashes in the same way (not sure where the Waves plugins are located, so not sure how to disable them).

Cubase Pro 8.5.30 64 bit, running on Windows 10 Pro v.1703 64-bit, i7-2820QM CPU 2.30 GHz, 8 GB RAM.

Hi,

Then it seems to be on plug-ins side, or dome permission issues. Maybe you could try to reinstall Cubase to “update” the permissions.

I think Martin is on the right track. I have a 3rd party plugin by XLN audio (electric grand piano). After the windows update, it said I had the wrong computer ID. They explained it on this page:

https://www.xlnaudio.com/support/topics/my-product-is-suddenly-not-authorized-wrong-computer-id-or-this-instrument-is-in-trial-mode

…and even provided a video on how to fix the problem. It worked.

So I think we’re looking at the OS change as somehow making the computer look unauthorized to the plugin providers. Based on the XLN example, the answer seems to be telling the 3rd party plugins that “you’ve changed computers”. I had to de-register my computer from XLN, then re-register it. Something like that seems likely to work.

Well, I got instructions from Waves on how to completely uninstall everything from them (including caches) and then install from scratch. Didn’t help.

If that includes re-registering, then maybe the creators update screws up more things than we think. That would make me consider rolling back the OS update. My XLN problem wasn’t with the install. I didn’t reinstall. It was with registration.

Actually I was thinking to reinstall Cubase.

I have reinstalled Cubase now (uninstalled first, then installed). That didn’t help either.

Worth a try (and seems to be becoming my stock answer to every question recently :confused: )

Update elicenser, run it as admin and then run maintenance (after any/every major W10 update)

I have now opened a request at Steinberg support with the following description, which summarises the suggestions I have tried from this thread:

After the latest Windows update (Windows 10 Pro v.1703 64-bit OS build 15063.413), my Waves plugins immediately closes Cubase when I try to open them. The Cubase stock plugins seem to work, at least those I have tried.

I have tried to uninstall both the Waves plugins and Waves central and deleted everything for Waves under %appdata% and %progdata% (after instructions from Waves support), and then the similar for Cubase.

Then I restarted the PC, re-installed Cubase (with the 8.5.30 update), ran the eLicenser (latest version) maintenance, then started Cubase to see if it was OK.

Then I installed the latest Waves Central, and installed just one of my plugins (Greg Wells MixCentric). Then started Cubase and created a new project, added a track and tried to add the plugin, but Cubase still crashes.

Then I restarted the PC, re-installed Cubase (with the 8.5.30 update), ran the eLicenser (latest version) maintenance, then started Cubase to see if it was OK.

To clarify…reinstall suggests you uninstalled first…in which case you can’t install from an update installer.
And did you run elicenser as administrator?

Yes to both questions. I uninstalled and installed Cubase (and ran the 8.5.30 updater afterwards), and ran the eLicenser as Administrator. Tried to uninstall and install eLc as well.

Found this: http://www.pendlebury.biz/waves-plugins-crashing-your-daw/
Even though it is from 2013 it addresses my problems pretty accurate, so II’ll give it a try.

Seems odd if this is the same issue that Waves wouldn’t have known about it…didn’t you have a non Waves plug also causing issues?
I did see this article after you posted but assumed it was not connected.

Let us know how it goes.

Yes, this started with another non-Waves plugin actually, so you’re right. But I have concentrated on the Waves part, since they have a support case running for me on this now.

I tried for this, but didn’t find any registry entries similar to the one mentioned here.

I have tried the Waves plugin in Reaper, and it works there. So it must be something with the interaction between Cubase and Waves.

Problem solved!
I got support from Waves, and they found entries in the Windows Event log saying Cubase had problems with some nvd*.dll. Tried to disable the NVidia graphics controller, and then the Waves plugins worked in Cubase again.
I enabled NVidia again and tweaked the settings for the graphic controller, and now it works satisfactorily.

Since Reaper had no problems with the Waves plugin, I guess this means Cubase and Reaper handles graphics differently.

Edit: Just got response from Steinberg support, which verifies the problem: “The Cubase 8.5 crashes are all due to the nvd3d9wrap.dll - this is an nVidia file.
It is possible that the recent update changed the driver installation, and that causes the crash on the 3D wrapper.”

Hello:

Two months ago I had no problems, but now, when I open MAAT DRMeter MkII and the try to close it, Cubase crushes. I searched and landed on this thread. I tried switching off my nVidia card and it worked: I can close DRMeter and Cubase doesn’t crush. Does anyone know please which settings in nVidia should be tweaked, so that the problem doesn’t arise with the card being activated?

Hi,

Here is the way, how to install NVIDIA card properly:

Please try this:

  • Uninstall the NVIDIA driver.
  • Download the latest Studio driver version from here.
  • Start the installation (as administrator).
  • Don’t install the whole package, use the Custom (Advanced) settings.
  • Disable everything (don’t install NVIDIA Experience, PhysX, etc.), keep just the video driver enabled.

Hello Martin:

You are the MASTER. Thank you, that did the trick.

I comment though that I have a relative old (but powerful) gamer notebook with a GeForce GTX 770M and I could not find a Studio version for the driver, only the Gamer version. But, as you said, I installed it as administrator, without nVidia Experience and PhysX. Now it works.

As I deactivated the card and the drivers changed, Cubase told me my soft e-licences will be deactivated. I don’t know, I have in 2019 wrongly activated Dark Planet as soft e-licence (I wanted USB e-licence) but now Dark Planet keeps working as soft.

Thank you again.