This Activation License Is Already Used

Hi Guys,

Anyone still having the problem to activate C11 ??
Today morning, I just opened the eLicenser Control Center to try again to authorize and now, and now i’m having 2 problems.
Sometimes it says that it can’t connect to the servers and sometimes it says that my license is already used.
I don’t know if it is a problem due to the connection or if it is really a problem with my license that maybe somehow it sent the info to the servers yesterday, but didn’t authorize my USB dongle.
I cannot perform the Maintenance and Syncronization routine on the control center because it still fails to connect to the servers.

Anyone with the same problem ?

Now after a few more tries (and failures) it says my license of CUbase 11 is activated (but I still got the same error of the activation server)


What error exactly do you mean, please?

It was the error saying that the server could not be reached… the same error that everyone is getting, but somehow I got it activated.