This New Windows Update keeps screwing up Dorico's Sound

Hi Elwin, sorry, too many threads going on at the same time. Yes, our experts did have a look and although they can see that the audio engine switches into longer processing cycles (what causes the drop outs), they still can’t say what is the real reason behind this behaviour. In any case, it must have to do with the Windows update, but what exactly we can’t say. From a scientific or engineering point of view it is of course of highest interest to find the exact cause of it, on the other hand, we have so many things to do, that we simply can not afford to spend too much energy into this. Especially because it is not a widespread phenomena, you are the first and only customer reporting such behaviour after a Windows update. So we hope for your understanding, if we - at least for now - cease the case.

Oh, okay. Thank you for letting me know.

It’s okay, I understand that you all are busy, and I look forward to your responses when you all have time to respond in greater detail.

I am guessing that this has to do with HP’s Audio system. I will attempt to fix the problem myself, as I have a few ideas now that I know it’s an audio engine issue, and I’ll let you know if something works.

Thank you so much for helping me with this problem, and I understand that I happen to be the only one with this problem. I look forward to hearing from all of you in the future when you all have time.

Hi folks,

sorry for coming back so late on this issue. In the meantime, we could now also reproduce the issue in-house and we did a fair bit of analysis on it. We do see what is going wrong, but we don’t know, yet, what is causing the issue, therefore can not fix it. But we are also in contact with Microsoft to get help from them.

Anyhow, what I want to say now is, we have found an easy workaround. People who experience this problem use the Generic Low Latency Driver. That driver uses by default the smallest possible audio buffer size of 10ms. If you increase that to 20ms (or if that does not do, even higher) then the distorted sound shall go away. To increase the buffer size, go to Edit > Device Setup. In the dialog click on ‘Device Control Panel’ button and in the then appearing window find ‘Audio buffer size’ and switch on ‘user definable’ and move up the slider below it.
Of course, this is just a workaround, it should also work with 10ms, but we are on the case and look for a proper solution.

Sometimes it is possible to have different sampling rates for different software. Make sure that Windows sound is set to the same sampling rate as your Dorico settings and vis a versa. This is one of the chief causes of jittery, noisy, silence and or malformed sound production.

And…any interface/sound card as well…

Hi folks, good news on this.

The guys from Microsoft were very helpful on analysing this and it was a whole lot of work. Now it seems we have found the culprit and that is NotePerformer. I’m already in contact with Arne Wallander. He will send me a fix version as soon as possible, so that I can test it. Once reconfirmed he will make it publicly available.

There is still the question, why it is now suddenly a problem, because the bug was already around for a much longer time. Must be also a little change in Windows that now uncovered it. Anyway, finally hunted down…

So Arne Wallander provided me a fix version and I tested it thoroughly and the bug is gone now :smiley:

I don’t know when he will go public with that version, but start nagging him, if it takes too long :wink:

Hello @Ulf,
Sorry, I forgot about this thread for a little bit. One thing, though, I did try testing it by switching to HALion, and the bug was still there. Maybe because NotePerformer already “messed” with the Driver Then.
So, with all the things pointing to NotePerformer and the Driver, would the issue have been fixed with an External Audio Interface?
Thank you for looking into this for me, I appreciate it!

@ Carlo Gesualdo,
How would I make sure the sample rate of Windows Sound is set to the same one that Dorico Uses?

Hi Elwin,
how did you test with HALion? When you switched to HALion when the sound was already messed up, then indeed the noise will continue.
But you can reset the driver by simply going to Edit > Device Setup, then click the Device Control Panel button, a new little window appears.
Just click OK in that window and that will reset the audio driver.
Another workaround is to set the ASIO buffer size to >= 20ms in that window just mentioned. With that buffer size the audio won’t get messed up either.

Lastly, Wallander Instruments already put out a beta version of NotePerformer with a fix for it. I just don’t know when the release version will go public.

@Ulf
I tested with HALion when the sound was already messed up.
Has anyone tried using an external audio interface with its own driver to see if the problem continues?
I tried setting the buffer size to 100ms when I tried the problem, and it still didn’t work.

Hm, with 100ms I don’t expect the problem to happen. On my laptop with built-in Realtek and Generic Low Latency driver the problem went away with 20ms.
However, with my external audio interface (Steinberg UR-22mkII) it is no problem at all, which by no means is a guarantee for any other audio interface out there.

Forgive my confusion, but I couldn’t quite understand what you meant by “which by no means is a guarantee…”
Did you mean that the problem won’t exist with a Steinberg Audio Interface, but might exist with a different external audio interface?

Yes, exactly.

Not sure whether this is related, but I’m experiencing severe distortion (very “chopped up” audio, I think) after using Dorico for some time. I am using USB audio, with the external device being a Yamaha P-515 digital piano. I am using the recommended (I believe) ASIO driver - the “Yamaha Steinberg” ASIO driver. Note that I am actually using the device for general Windows apps at the same time, so perhaps I am pushing things too far. However, I didn’t have this problem until recently, so maybe it is the Windows update.
The easiest way to reset the condition is to power cycle the P-515. I can leave Dorico and the other apps running - power cycling alone clears it.
The main reason I am sharing the audio device with Windows is to allow me to switch back & forth between Dorico, and an audio transcription application. (actually, if it’s possible to configure Dorico to use external MIDI for the Dorico “beep”, I won’t actually need any audio device in Dorico at all, but I can’t see how to do that…)
The choppy audio occurs not only in Dorico - it occurs in my other app as well, which is using standard Windows audio. (not ASIO)

Hi Greg, I can’t find enough info on the P515. Do you say that you use it as an audio interface as well? So all the sound from the computer goes to the speakers of the P515? If that is the case, then the reason for distorted audio can not be Dorico, because all audio from the computer is broken. Please clarify.
Also, when you get choppy audio, please do in Dorico ‘Help > Create Diagnostics Report’ and attach the corresponding zip here. Thanks

Ulf - your understanding is 100% correct, and I agree - the needle of suspicion isn’t on Dorico. Will send diag report. Thanks.

FYI, I noticed that I had some services running which I know cause serious system “pauses” in real time audio apps, and I have now stopped them, and so far this problem hasn’t occurred, but will report back if it ever does. The services are Dell system monitoring related - I don’t know which specific one(s) cause the problem - I simply stop them all. If this turns out to be the problem, I apologise for wasting your time.

Thanks for reporting back, Greg.

Hello @Ulf,

I was unaware as to what NotePerformer was the latest. The Version I have is 3.3.1 and I am downloading 3.3.2 right now. Is 3.3.2 the Beta Version you were talking about? I read in the NotePerformer version history that 3.3.2 has the correction.

Hi Elwin,
yes, 3.3.2 now officially got released, that’s the one you want to have.
Should you have problems getting that going, let me know. Some users had the issue that NP would not turn up in the list any more, but we have a solution for that.