Three flows across two pages

I’m attempting to get layout three flows across two pages. The first and second flows in the attached project should be on the first page (including a small amount of extra vertical space between flows 1-2) and the last flow on the second page.

When I watch this video that was referenced in other posts I seem to lose the ability to keep my title/subtitle/composer information on page 1 and moving the music frames to different locations on the page doesn’t seem to change the position of music.

Any help would greatly be appreciated. Thank you in advance!

layoutHelp20210124.1.dorico (1.4 MB)

Sorry, I’m not clear on what you want exactly. Flows 1 and 2 on page 1, and flow 3 on the 3rd page? Or did you mean the 2nd page?

Assuming you meant the 2nd page, I think what you’re looking for is this setting:

Apologies; yes, the third flow should be on page 2.

When I check Page Setup > New Flows > Allow on existing page I’m left with three music frames that can’t be moved around.

If I try and modify my default first page to only choose my first flow for the first music frame, the remainder of the music is lost.

Modifying the page:

Result:

Don’t alter the frames. Just use the staff spacing tool to move the staves in Flow 2 down.

Is this kind of what you’re looking for? I’m not quite sure I understand the specifics, but if the general thing you’re after is to get flows 1 and 2 onto page 1, and flow 3 onto page 2, it seems like what Dan says is correct; you shouldn’t be messing with the music frames in your master page. layoutHelp20210124.1fix.dorico (1.4 MB)

Here’s a quick vid to demonstrate (note: I’ve set the layout properties to default, because it looks like a lot of things were unnecessarily modified in there while you were trying to figure it out. I just wanted to start from a clean slate, but obviously some of them might need to be set back again): https://youtu.be/AK4ic3we0e4

1 Like

Thank you vxla for this post !!
It was a big problem for me too !
If in “layout options” the “new flows” would have been by default on “allow on existing page” i could have save a lot of time looking for a solution…what i 've found then was to use Layout frame chains (LA,LB ect…).
Indeed i think it’s better to work with Master page frame chains.
I’m quit sure that this problem if not cleared enough early could put off some beginners with Dorico ! But once it is clear you know it is very powerful !
So thank you vxla, dankreider and snakeeyes021 !!
Very useful post :+1: :clap:
Olivier

For the vast majority of use cases, there’s no need to touch the Master Frame Chain. If you want some flows to start immediately after the previous, and others to start on new pages, set the Layout Option to allow flows to continue immediately, then put Frame Breaks at the start of each flow you want on a new page.

2 Likes

Thank you for the responses and especially thank you to @snakeeyes021 for taking the time to make the video.

Originally the idea I had when putting flows in different frames was to have a gap of whitespace between the bottom of flow 1 and the top of flow 2 (without having flow headers enabled)…about the size of the red box in this image:

I do see that this can be achieved by dragging the music of flow 2 vertically in Engrave mode, for I didn’t know if this was the “Dorico Way™” or if separate music frames was preferred.

Thanks again.

If you want a more automated solution than using the Staff Spacing tool, you could take advantage of the spacing that Flow Headings provide, but clear the content of the Flow Headings, like so:

margins

Though I’ve not showed it in the GIF, it’s possible to define multiple Flow Headings from the right panel of Engrave mode, so you can absolutely get away with showing empty Flow Headings in one layout while showing regular Flow Headings in other layouts.

2 Likes

This did exactly what I needed. Thank you very much.

Which brings me to a feature request:
In a bundle of baroque sonatas, I wanted to include just a little extra white space between the (relatively short) movements, just like the example above. But: the extra white space is unneeded before the first flow on the page. There is a layout option to omit the flow heading before the first flow, but it really only applies to the very first flow in the project.
In my recent project, I assigned the First master page to the page with the first movement of each sonata. Unfortunately, I couldn’t omit the unneeded flow heading after sonata 1 (without making a mess with page overrides etc.).

Actually, I have a double FR:

  1. A layout option under the Vertical Spacing settings where I can add a little extra white space between flows on the same page, i.e. without the need to insert flow headings and/or flow heading changes. Of course, this extra white space would be ignored if a flow starts on the top of the page (like you would do with paragraphs in text if they are otherwise separated by white space.)

  2. Flow Headings now have a setting ‘Show flow headings: Never / Not for first flow / For all flows’ (see above). I’d like to suggest an extra option: ‘Not for first flow on (any) “First” master page’. This would make all First pages the same, and save us some overrides and messing around.

Apart from this all, it would be nice if flows could be grouped hierarchically, with the possibility to have different kinds of headings and ‘first’ pages according to the grouping of flows. It’s a suggestion made earlier, so I leave it at that.

2 Likes