Time signature change at DC

I need to change the time signature before my DC to 2/4 as shown in red in the attachment. When I do that, the time signature in the coda changes to 2/4, but needs to stay in 3/4. Any ideas how to solve?

Unfortunately I think the only way will be to add the time signature digits at the D.C. using Shift+X text.

That worked - thx. Now if I can only move the double bar before the 2/4 without losing the 5 staff lines behind 2/4.

What if you created a time change with a very small pickup (1/64th note). Hide the rest by setting the Alpha channel to 0. Adjust spacing in Engrave mode if needed. You’d get a tiny hiccup in playback but it would look good.

TS change.png

Can this be done while hiding the bar to the right of 2/4? I don’t think it is supposed to be there…

Ed, do you mean hide the barline? I think this can be done in Write mode by pressing the Delete key.

Unfortunately you can’t easily delete the barline at the end of a system, currently.

I don’t think you can delete the barline either…will leave the whole thing as is…close enough.

I think I’ve found a way. If you don’t need dashed barlines elsewhere, do this…
Set the barline to dashed, then in Engraving Options > Barlines, set the dash length to 0.

Genius. Thanks for that.

Success! I wound up doing the following.

  1. Added an extra bar in 3/4
  2. Hide 3/4 TS
  3. Add 2/4 as glyphs
  4. Hide bar rests by setting alpha to 0
  5. Made bar only as wide as 2/4 glyphs
  6. Added dashed barline and set dash length to 0 as Craig F recommended
  7. Renumbered following bar to 1 less than it was to account for new, fake bar