Time signature mismatch

Hi everyone,
I’m having a problem with changing a single measure’s time signature. I want it to be a 7/8 measure, but I’m only getting an option to input 3/4s worth of notes. I’ve uploaded a video showing the problem in trying to change the measure to different time signatures here:
https://youtu.be/iKV2zaRu6tI

any ideas how to fix this?
Thanks!

Turn on Insert mode before you change the meter to 7/8
OR
Delete the 4/4 in the following bar before you change the meter to 7/8
OR
Change the meter to 7/8, then select a note or rest within that bar, type Shift+B and then type 1/8 Enter